[SOLVED] WiPy 3.0 firmware



  • I tried updating firmware of my fresh WiPy 3.0 today and noticed that Pycom Firmware Update shows only WiPy 2.0, LoPy and SiPy as available board options. Quite lightheartedly I selected WiPy 2.0 and flashed with 1.10.0.b1.

    Updating to 1.10.0.b1 for WiPy 2.0 made my board fail to boot with repeated Guru Meditation errors like the following:

    rst:0xc (SW_CPU_RESET),boot:0x13 (SPI_FAST_FLASH_BOOT)
    configsip: 0, SPIWP:0xee
    clk_drv:0x00,q_drv:0x00,d_drv:0x00,cs0_drv:0x00,hd_drv:0x00,wp_drv:0x00
    mode:DIO, clock div:1
    load:0x3fff9028,len:8
    load:0x3fff9030,len:932
    load:0x4009fa00,len:0
    ho 12 tail 0 room 4
    load:0x4009fa00,len:13232
    entry 0x400a04e8
    Guru Meditation Error of type LoadProhibited occurred on core  0. Exception was unhandled.
    Register dump:
    PC      : 0x4008215d  PS      : 0x00060130  A0      : 0x800d27e4  A1      : 0x3ffe3c00
    A2      : 0x00000001  A3      : 0x00000000  A4      : 0x3ffc3e98  A5      : 0x3ffc0ac4
    A6      : 0x00000800  A7      : 0xfffff3ff  A8      : 0x0f3d24d4  A9      : 0x3ff49060
    A10     : 0x3f41c72c  A11     : 0x0ffd104f  A12     : 0x00000034  A13     : 0x00000000
    A14     : 0x000008ff  A15     : 0x00000000  SAR     : 0x00000017  EXCCAUSE: 0x0000001c
    EXCVADDR: 0x0f3d24d4  LBEG    : 0x400976d4  LEND    : 0x400976df  LCOUNT  : 0x00000000
    

    I also tried to flash from command line using esptool.py with image returned by findupgrade query for WiPy:

    https://software.pycom.io/findupgrade?key=wipy.wipy%20with%20esp32&redirect=false&type=all
    

    And I tried erasing flash using esptool.py prior to flashing, with no luck still.
    Finally, I tried flashing with the original firmware version (1.7.1.b1), which didn't work and I'm either getting Guru Meditation all the time, or my heartbeat LED is solid red.

    Are WiPy 3.0 firmware images different from WiPy 2.0? If so, where can I get them from?

    Thanks



  • @danielm That was it. Thanks a ton! <3



  • Try to modify updater.py according to Update in the first post:
    https://forum.pycom.io/topic/2097/new-firmware-release-1-10-0-b1-external-4mbyte-ram-support

    I experienced repeated Guru Meditations Errors with latest FW on L01 in case it was flashed with unmodified updater.


 

Kickstarter Launch-Pylife

November 2018





Back Us On Kickstarter >

Pycom on Twitter