Problem Upgrading Firmware in Mac

  • Hello everyone,

    So recently I purchased a few LoPys, and been trying to upgrade the firmware but with no luck. I have tried the software for the Mac, but the software won't even launch (it tries to then quits). I've also tried the Linux method, from the Mac Terminal. I get into the dialog box, but then when I put the path of the serial port it says upgrade failed. The Mac can detect the LoPy serial port and I've followed every instruction available. Any help for this?

    Thank you.

  • Pybytes Beta

    @Roberto Thanks, it did work for me. A simple thing, but on the one instruction screen, you might add as the last item, "turn device on". That way when "Continue" is pressed, the device will show up in the drop down list on the next screen. No big deal though, as I just hit "Go back" and then plugged it in.

  • Hi @jomifo,
    This issue was fixed on version "a". Please download it and try again

  • Pybytes Beta

    Same thing was happening for me on Mac as well with the .9.3.b2 version- Updater tool would open and then close right away. Haven't tried the latest .9.3.b2a though.

  • Hi @Roberto

    Thank you for the update. I downloaded the new tool and now at least the application runs and I can try and upgrade. Will try tomorrow on the LoPy when I get back to my office.

  • Hi @kgadeshi
    There is a new version of the Firmware upgrade tool in the web site with the name

    It contains some bug fixes that might help you

    When running it make sure that
    a. You copy it to your Application Folder
    b. Open it using Ctrl+Click or enable applications from other sources in your mac settings (if not you will get a screen telling you how to do so)

  • The firmware update for Mac doesn't work. if you upgrade with windows it will work but then you can not access your Lopy trough FTP.

    So in other words better not upgrade and stay with the firmware you have until they release something that works.

Log in to reply

Pycom on Twitter