LoPy stopped working, gets hot, Broken?



  • Hi,

    I got a LoPy yesterday to setup as a TTN nano gateway so I could experiment with some other nodes once they arrive.

    However I notice that it stopped pinging TTN and got really hot. I tried with a different power method and the exact same thing happened.

    It also now spits garbage out over UART. See attached.
    0_1512324477610_Screenshot from 2017-12-03 18-07-35.png

    I also tried resetting it back to the factory defaults however no luck.

    Thanks



  • Just tried updating the firmware. Lights blink on my UART board however it said failed.
    0_1512337727762_Screenshot from 2017-12-03 21-36-42.png
    Connected GP23 to GND like I did originally to update the firmware.

    Rather odd as I took precautions to make sure I used only the 3v3 UART however like explained It was just plugged in normally when it stopped working. Odd!

    I'll return it to the retailer and request a replacement as I was rather enjoying it.

    Thanks



  • @ryanteck A device getting really hot is not a good sign. The normal power dissaption is 600mW. Looks like the device is broken.

    P.S.: Connecting P12 to3V3 just skips the execution of boot.py and main.py.



  • @livius Yep I checked it was a 3V3 Device and was in turn powering the UART converter logic side from the 3v3 rail of the LoPy. No other sensors were connected and it actually stopped working while UART was disconnected. (Just being powered from a 5V source on the 5V In Pin). I then connected it to my UART Device after it didn't respond to TTN for a few minutes.

    I haven't tried to flash it again so will do that in a bit. However I attempted to reset it to factory firmware using P12.



  • @ryanteck
    What do you use with it?
    Did you remembered that it is 3V3 device? e.g. your uart converter can be 5V and can broke your device. Also sensors connected to 5V.

    What if you tried to flash it once again with firmware? Is this process working?


 

Pycom on Twitter