pymakr installation fail on atom 1.23.1 x64



  • Hi, The installer is saying it wants to install pymakr 1.0.3 ("the latest that is compatible with your version of Atom"). On installing I get ..

    Installing “Pymakr@1.0.3” failed.Hide output…
    fs.js:640
    return binding.open(pathModule._makeLong(path), stringToFlags(flags), mode);
    ^

    Error: ENOENT: no such file or directory, open 'C:\Users\patmo.atom\packages\Pymakr\package.json'
    at Error (native)
    at Object.fs.openSync (fs.js:640:18)
    at Proxy.fs.readFileSync (fs.js:508:33)
    at Proxy.fs.readFileSync (C:\Users\patmo\AppData\Local\atom\app-1.23.1\resources\app\apm\node_modules\asar-require\lib\require.js:86:27)
    at C:\Users\patmo\AppData\Local\atom\app-1.23.1\resources\app\apm\lib\install.js:476:42
    at fn (C:\Users\patmo\AppData\Local\atom\app-1.23.1\resources\app\apm\node_modules\async\lib\async.js:582:34)
    at Immediate.<anonymous> (C:\Users\patmo\AppData\Local\atom\app-1.23.1\resources\app\apm\node_modules\async\lib\async.js:498:34)
    at runCallback (timers.js:649:20)
    at tryOnImmediate (timers.js:622:5)
    at processImmediate [as _immediateCallback] (timers.js:594:5)

    I did actually try a manual install, but that was even worse!

    Thanks!

    Pat



  • @ralph great stuff, thanks. What a PITA error :(


  • Global Moderator

    @patmolloy This issue has finally been fixed today. The problem was that Atom stopped supporting package names with uppercase. It's been changed to lowercase now in Pymakr pymakr version 1.2.5. Unfortunately, you will lose the global package settings as a result of this.



  • @ralph -- thanks. I'm afraid I still have some problem or other. This is a completely fresh atom install

    0_1513267497993_fa455fa6-a18b-4223-ba57-d20db27603d8-image.png Installing “Pymakr@1.2.3” failed.Hide output…
    fs.js:640
    return binding.open(pathModule._makeLong(path), stringToFlags(flags), mode);
    ^

    Error: ENOENT: no such file or directory, open 'C:\Users\patmo.atom\packages\Pymakr\package.json'
    at Error (native)
    at Object.fs.openSync (fs.js:640:18)
    at Proxy.fs.readFileSync (fs.js:508:33)
    at Proxy.fs.readFileSync (C:\Users\patmo\AppData\Local\atom\app-1.23.1\resources\app\apm\node_modules\asar-require\lib\require.js:86:27)
    at C:\Users\patmo\AppData\Local\atom\app-1.23.1\resources\app\apm\lib\install.js:476:42
    at fn (C:\Users\patmo\AppData\Local\atom\app-1.23.1\resources\app\apm\node_modules\async\lib\async.js:582:34)
    at Immediate.<anonymous> (C:\Users\patmo\AppData\Local\atom\app-1.23.1\resources\app\apm\node_modules\async\lib\async.js:498:34)
    at runCallback (timers.js:649:20)
    at tryOnImmediate (timers.js:622:5)
    at processImmediate [as _immediateCallback] (timers.js:594:5)


  • Global Moderator

    @patmolloy You should be able to update to Pymakr v1.2.3 now. Let me know if it fixes your issue



  • This post is deleted!

  • Global Moderator

    Hi @patmolloy, thanks for the report. I got this same report yesterday and I now realise that the package is not marked as compatible with 1.23.1 yet. I'l test it, update the compatibility and then deploy it as a new version today!


 

Kickstarter Launch-Pylife

November 2018





Back Us On Kickstarter >

Pycom on Twitter