Pymakr will not connect - inconsistent following firmware 0.9.3.b2



  • Hi,

    Two LoPy - both working fine without any unknown issues. Then I run the updater for firmware version 0.9.3.b2 and all succeeded OK.

    Apart from now, Pymakr will connect to the one Lopy and not the other.

    I have reflashed it, reset it to factory settings - everything that my limited knowledge allows me to do.

    Does anyone have any idea why Pymakr can't connect or is there any test I should do?

    Thanks in anticipation.



  • @abilio Thanks for your response and for the Pycom team on working on the solution to the issues. I did the same thing (firmware upgrade to 0.9.6.b1, pymakr 1.0.0.b7) and I'm using Windows 10.

    I am able to:

    • FTP into LoPy with read and write access to the files (i.e. I can update my boot.py)
    • telnet to LoPy via putty
    • connect to LoPy via WLAN using another computer (Mac OS X)

    I am not able to:

    • connect to LoPy via serial port (using both PyMakr and putty). PyMakr shows the following, and it seems like it connects to it then drops off:
      0_1480118841643_upload-0226ee5e-dfa4-472a-a010-67a51a93b6bc
    • connect to LoPy via wlan using Pymakr

    Also, I've kept the putty Window (serial) when I try connecting via my Mac (wlan) or Windows (PyMakr) and it prints the following during the attempts:
    0_1480119798894_upload-28c78253-0a34-4575-a745-6454fede1651

    I've noticed in the new PyMakr, it has the Soft-reset settings as part of the configuration. Does this mean, the if machine.reset_cause() != machine.SOFT_RESET... is not needed for the boot.py? I've tried it with and without, and I have the same results. It should just work with this right?
    import os
    from machine import UART
    uart = UART(0, 115200)
    os.dupterm(uart)



  • @abilio updated to latest 0.9.6.b1a and pymakr 1.0.0.b7

    Can't connect to LoPy on COM on either Linux or Windows. CAN connect over LoPy AP WIFI on Linux!!
    Cannot telnet to the LoPy, however I don't need that functionality. Last firmware released at least let me ftp to it, but I could only copy code to my PC, not put files onto the LoPy.

    Anyway, code synced and updated to the LoPy!! I'm happy with this as a start, thank you and the team for their hard work in getting this resolved.

    I've connected the LoPy to my local wifi now, and can confirm, it works over WIFI, not just LoPy AP. Only Linux though.

    I work with a local github server so this will do just fine.



  • @abilio when was that released? I downloaded the latest version yesterday and installed using the firmware update tool provided with Pymakr. The very first thing I did was update the firmware. All issues were with this version.



  • Hi @HellDesk, @tarmael, @kwix, there is a new firmware upgrade (0.9.6.b1) that fixes an issue that caused Pymakr to fail over serial port. This probably solves your problem. Please try it and post back any result.



  • Lucky you.



  • i am able to connect to my WiPy 2 by COM port by newest Pymakr 1.0.0.b7 :)



  • Hi-
    I just received my WiPi 2.0 the other day and immediately upgraded the firmware (as I usually do with such things). Now I'm able to telnet into it just fine, and I can use Putty to get a serial console, however Pymakr fails as many others have said.

    My boot.py is set to default. Nothing has been changed from factory except that I updated the firmware out of the box.

    Here is my boot.py:

    import os
    from machine import UART
    uart = UART(0, 115200)
    os.dupterm(uart)
    

    Any word from Pycom about this? I'm thinking about trying to reach support or going on Github and posting a bug for Pymakr if I can't find one yet.



  • I'm also having this problem on Linux and W10.

    I received my LoPy's the other day, they worked fine for about a day then they stopped accepting connections.

    I've never been able to connect to them via ssh, telnet or COM on Linux or W10.

    I can connect to the LoPy AP, and the Pymakr will connect, however it will not let me sync my code to the LoPy.



  • @Ralph ditto - upgraded to latest firmware 0.9.5b1 and it works on Windows 10 but only if connected via wlan. Thank you for your help - really appreciate your immediate responses.

    I've also tried serial connection via putty and Pymakr - it does not work for me and I get the same issues as before (i.e. QStackedWidget warning message, last 7 days error message and error communicating with LoPy).



  • @Ralph @daniel Hi guys, just a quick note of thanks. Following the release of firmware 0.9.5.b1, I can now happily connect to the LoPy's using WiFi and Com (using Windows 7).

    Look forward to receiving the new PyMakr which will hopefully get rid of the message related to not being able to contact the PyCom servers within the last 7 days (on startup).

    Also thank you @LoneTech for sorting the pin issues (32 and above), that work was much appreciated!

    We can at least get on with some testing of the boxes.



  • still can not connect to WiPy2 throught CMM by pymakr with current firmware 0.9.5.b1
    i work on Windows platform (Windows 10)



  • @Ralph Can I ask exactly when the next release will be available? Also, forgot to mention the versions I'm using:
    LoPy 0.9.3.b2
    Windows 10
    Pymakr 1.0.0.b6
    Device:COM3

    @livius that's nice to know! though I meant in general...or most people are just not using Windows. Will attempt to use Mac OS X, hoping I get somewhere.



  • This post is deleted!


  • @kwix
    i have exactly the same - you are not alone



  • @Ralph hi again, I tried connecting over USB and kept a screen session open to the serial port and this is what I got when I try to connect via Pymakr:

    0_1479428518180_upload-a8a2a387-3c1a-4dd5-b739-3ce03e934b73

    Same error messages obtained in the Pymakr: QStackedWidget Warning, the popup window, though looking at the timestamp, I think it was from yesterday.
    0_1479428630404_upload-d78be6d2-ce02-42a9-a8bb-edf50f12ea58

    In addition to those, another pop-up message appears:
    0_1479429208151_upload-f63e8ee1-71a3-438e-8868-e326f5049472

    I've checked my device manager and it recognises whatever's plugged into COM3 as an FTDI device. I'm probably doing something wrong here - I have not come across anyone else having the same issues as I am :(

    I will just wait for the next release and hopefully it would work out - unless you have other suggestions that I should try? Really appreciate your immediate response.



  • Hi @kwix, which firmware version are you using? We discovered a bug that's in the latest few versions (0.9.3.b2 and up, as far as we know), that makes the connection to Pymakr fail (this issue) It could be that this is your problem, in which case you'll have to wait for the next release. Did you try connecting over usb?
    A good way to check what's going on, is keeping a connection open to the board via the terminal while trying Pymakr, to see what's going on on the board and with your code. If you are using telnet in Pymakr, keep a screen session open to the serial port from the command line. Or the other way around.



  • @Ralph hiya - thanks for the detailed response. I have a kept the telnet connection open and it seems to be working fine:

    0_1479339966903_upload-803ca7d0-56b8-4bef-bd73-36d7d222d9ba

    I tried connecting to Pymakr again while telnet connection is open, and now I am only getting error message, unlike before where it connects for a few seconds before it disconnects again:

    0_1479340035521_upload-569f5273-7b43-429f-8042-db950597588c

    I don't get any messages from command line of the telnet connection but I got a different pop-up error message from the Pymakr:
    [0_1479340260779_LoPy-ErrorMsg.txt](Uploading 100%)

    Not sure if this is related to this or just a result of me disconnecting to lopy-wlan so I can post this entry.

    Is there any other places where I can see some logs? Or maybe i'm just doing something wrong/missed off?



  • @kwix Good to see you made it a step further.

    The import machine is definitely needed, since you're using it on line 11. First of all, after editing the boot.py file, you need to reboot the device so that it actually executes. Pressing the reset button on the board is enough.

    From your screenshot of the device console in Pymakr, I see that it does connect the first time, but then imidiately disconnects again, and after that doesn't manage to reconnect. I suspect the code breaks somewhere shortly after connecting. A good way to debug is to keep a telnet connection open from the commandline while trying to connect from Pymakr. This way you can see if any exception occurs that messes things up.

    The QStackedWidget error will be fixed in the next release (either this weer or next week) but you should still get it to connect anyway. We will definitely improve Pymakr's error messages so you can get more info on this in Pymakr itself.

    Let me know if that helps or if you manage to get more information on the issue you are having.



  • @Ralph thanks for the help. I've missed off selecting the passive mode and now I am able to access the boot.py file. I've updated the boot.py file to something like below:

    0_1479173265574_upload-83f54b0f-935f-4816-8784-499d79006457

    I've tried both with and without the commented "import machine"

    When I go to Pymakr, it reaches REPL then after a few seconds the popup window with Warning QStackedWidget::setCurrentWidget: widget ... appears. I'd click OK to close the window then I get the same error message that an error occurred while communicating with the Pycom device:

    0_1479173486024_upload-dd21b05c-28f6-41c3-88bf-e7d44f0070af

    After that it will just keep displaying the same error message until I "reset" the device (unplug and plug the USB cable into the LoPy) and reconnect to the lopy-wlan. Also, is it normal to "reset" the LoPy everytime I switch between Filezilla to edit the boot.py and PyMakr to test it?

    Please suggest a better approach for this as I think I might end up breaking the board if I keep on doing this.


Log in to reply
 

Looks like your connection to Pycom Forum was lost, please wait while we try to reconnect.