Fipy Firmware

  • Hi,

    I have just received my 2 x FiPy and Expansion Board yesterday.
    When I perform firmware update according to the pycom doc, only one of them update firmware successfully. May I know what is the cause? And is there other way to update firmware manually? Thanks.


    1. Wired G23 to GND pins on Expansion Board.
    2. TX & RX connectors on Expansion Board are secured.
    3. Insert FiPy module in Expansion Board (same Board for both FiPy).
    4. Connect Expansion Board to Windows PC via USB.
    5. Run pycom-fwtool.exe to perform firmware update.


    1st FiPy (after successful update)

    >>> os.uname()
    (sysname='FiPy', nodename='FiPy', release='1.15.0.b1', version='v1.8.6-849-baa8c33 on 2018-01-29', machine='FiPy with ESP32', lorawan='1.0.0', sigfox='1.0.1')

    2nd FiPy (unsuccessful update)

    >>> os.uname()
    (sysname='FiPy', nodename='FiPy', release='1.10.0.b1', version='v1.8.6-834-g5677703c on 2017-11-13', machine='FiPy withESP32', lorawan='1.0.0')
    >>> binascii.hexlify(machine.unique_id())

  • @seb It solved! Thank a lot.

    Steps : close PuTTY (put to download mode) and start firmware update tool.

    0_1518520822108_Fipy No Error Message.png

  • administrators

    @philip_teoph said in Fipy Firmware:

    Yours : boot:0x2 (DOWNLOAD_BOOT(UART0/UART1/SDIO_REI_FEOV2))
    Mine : boot:0x3 (DOWNLOAD_BOOT(UART0/UART1/SDIO_REI_REO_V2))


    The difference in the messages does not matter, most devices I have checked display the message the same way yours does (I'm not sure what the differences actually signify). The fact you see the waiting for download message means your FiPy is successfully entering the firmware download mode. Once you see this message can you then close all open connections to the device and try the firmware update tool again. It is important that no other application has the serial port open.

  • @seb !0_1518486085160_firmware via serial port.png

    Please note that there is difference in console message displayed:

    Yours : boot:0x2 (DOWNLOAD_BOOT(UART0/UART1/SDIO_REI_FEOV2))

    I manage to reboot into download mode as advice. Whats next please?


  • administrators


    In regards to the older firmware not mentioning sigfox, this is due to the firmware thats shipped with the device not supporting sigfox. This was added in a firmware update that was released shortly after the device was released.

    Could you please connect to the serial port of device thats giving you trouble (either via pymakr or putty), this should show you an interactive prompt you can type code into. If you then connect a wire between Gnd and G23 of the expansion board and press the reset button on your fipy, it should reboot into download mode. You should see the following on the serial port, can you confirm?

    waiting for download

  • @seb I bought and received both FiPy at the same time and try to update both FiPy modules using same Expansion Board with same pycom firmware update software using same Windows PC.

    The first FiPy updated successfully.
    The second FiPy unsuccessfully in updating.

    The error is as follows:-
    0_1518405183882_Fipy Error Message.png

    Note: I had try to uninstall and reinstall the pycom firmware update software with the url link provided by you (i.e. pycom_firware_update_1.1.6.b0.exe), but same error message appears.

    I have also just realize the following:-

    Please advice.


  • administrators



    When you tried to update the firmware on the second FiPy, what error did you receive? Are you using the latest updater? (

  • I have similar problem. FIPY doesn't work.
    I tried also building from GIT and enabling logs. Seems that is HW/power issue and the modem is not responding . On GPY same actions have results in modem GSM initialized.

                rst:0x1 (POWERON_RESET),boot:0x13 (SPI_FAST_FLASH_BOOT)
                configsip: 0, SPIWP:0xee
                mode:DIO, clock div:1
                ho 12 tail 0 room 4
                entry 0x400a05d4
                GPIO direction configured
                uart_set_pin done
                uart_driver_install done
                MicroPython baa8c33-dirty on 2018-02-09; FiPy with ESP32
                Type "help()" for more information.
                AT COMMAND: [AT..]
                AT: TIMEOUT
                ONLINE, DISCONNECTING...
                AT COMMAND: [ATH..]
                AT: TIMEOUT
                AT COMMAND: [ATH..]
                AT: TIMEOUT
                AT COMMAND: [ATH..]
                AT: TIMEOUT
                AT COMMAND: [ATH..]
                AT: TIMEOUT
                STILL CONNECTED.
                AT COMMAND: [ATH..]
                AT: TIMEOUT
                AT COMMAND: [ATH..]
                AT: TIMEOUT

Log in to reply

Pycom on Twitter

Looks like your connection to Pycom Forum was lost, please wait while we try to reconnect.