REPL not showing up after



  • I basically uploaded a project into my fipy without safe boot. After that the device has stopped showing the REPL in the atom plugin. What's weird is that even after resetting, ctrl+c or even updating the firmware of fipy and the pysense board, the fipy still responds the same way. I have tried all the available methods of troubleshooting. I am assuming because I did not turn on safe boot my device has stopped working. Currently when I try to connect the device either I get "> Failed to connect (Error: Port is not open). Click here to try again" or just a blank screen on the atom pymakr console. Another observation was that the device does work if I run a file on it. I tried to run a bluetooth file and my mobile was able to detect the fipy.
    Any ideas on what could be the issue?



  • @robert-hh yeah the P12 reset worked out. Thank you :)



  • @mdk22 You could try a safe boot, by connecting P12 to the 3.3v Pin and push the reset button. If the problem is within boot.py or main.py, they wil be skipped.
    If you have also already loaded V1.17.0.b1, you can also try to simply press Ctrl-F in the Atom console.


Log in to reply
 

Pycom on Twitter

Looks like your connection to Pycom Forum was lost, please wait while we try to reconnect.