Nano gateway restarts suddenly serial out shows Guru Meditation Error



  • I am ruining Lora nano Gateway in Lopy 1 in firmware 1.10.2.b1 .

    I am trying to build 24x7 application.

    Nano gateway runs for hours Getting data from node via Lora WAN communication after certain time Gateway Restarts...I request some solutions for this Crashing issue

    Thanks.


    Guru Meditation Error of type LoadProhibited occurred on core 0. Exception was unhandled.
    Register dump:
    PC : 0x400fb704 PS : 0x00060030 A0 : 0x800dd300 A1 : 0x3ffda8a0
    A2 : 0x00000001 A3 : 0x00000001 A4 : 0x00000000 A5 : 0x00000001
    A6 : 0x00000000 A7 : 0x00060023 A8 : 0x800fa51a A9 : 0x3fff0b30
    A10 : 0x00000001 A11 : 0x00000001 A12 : 0x3ffe7150 A13 : 0x3ffe7150
    A14 : 0x3fff0ca0 A15 : 0x3fff0c00 SAR : 0x0000001e EXCCAUSE: 0x0000001c
    EXCVADDR: 0x00000001 LBEG : 0x40098620 LEND : 0x4009862b LCOUNT : 0x00000000

    Backtrace: 0x400fb704:0x3ffda8a0 0x400dd2fd:0x3ffda8c0 0x400dd367:0x3ffda8e0 0x400dd7f5:0x3ffda910 0x401045a6:0x3ffda930 0x400f35d2:0x3ffda960 0x400eff91:0x3ffda990 0x400fb1e7:0x3ffda9b0 0x400f365c:0x3ffdaa50 0x400eff91:0x3ffdaa90 0x400effbe:0x3ffdaab0 0x400dd887:0x3ffdaad0 0x400ddb3c:0x3ffdab70 0x400dcb83:0x3ffdab90

    ================= CORE DUMP START =================
    UCYAAAsAAABsAQAA
    PIT9P+CC/T80hP0/
    4IL9P9CD/T+3xQcAMEL8PzBC/D88hP0/KEL8PxgAAABsef0/bHn9PzyE/T8AAAAA
    AQAAADh6/T9UbXIgU3ZjALKYKdeQa7QAAAAAADSE/T8AAAAAIQAGAAEAAAAAAAAA
    AAAAAAAAAAAAAAAAAAAAAAAAAACACf0/6An9P1AK/T8AAAAAAAAAAAEAAAAAAAAA
    uFFAPwAAAAAcjAlAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA

    • list item
      AAAAAAAAAAAAAAAAAAAAAAAAAADQ1/s/CLH8P2By/D8AAAAA0Nf7Pwix/D9gcvw/
      AAAAALzFBwAAAAAAZ29MHv////8AAAAAAAAAAAAAAAA0Zf0/LN4RQPUAAAAEAAAA

    ================= CORE DUMP END =================
    E (657) esp_core_dump: Skipped 1 tasks with bad TCB!
    E (662) esp_core_dump: Crashed task has been skipped!
    Rebooting...
    ets Jun 8 2016 00:22:57

    rst:0xc (SW_CPU_RESET),boot:0x13 (SPI_FAST_FLASH_BOOT)
    configsip: 0, SPIWP:0xee
    clk_drv:0x00,q_drv:0x00,d_drv:0x00,cs0_drv:0x00,hd_drv:0x00,wp_drv:0x00
    mode:DIO, clock div:1
    load:0x3fff9028,len:8
    load:0x3fff9030,len:1060



  • @shiva-shankar Are you sure that you are using V1.17.3.b1 on your device, together with the lastesrt copy of the nanogateway.py script? What are the responses to :

    import uos
    uos.uname()
    uos.listdir()
    uos.stat("nanogateway.py")
    


  • @robert-hh thanks for the support... I am not able to solve this issue Downlink timestamp error!, t_us: 4293852601



  • @shiva-shankar I think that's something I added in the main loop too. I have a LoPy nanogateway running since 4 days now, Release V1.17.3.b1. It was stable before too, but I rebooted it several times for testing.



  • @robert-hh

    hi
    Resolved my issue
    I am able to Long run LoPY now after adding gc.collect



  • @robert-hh said in Nano gateway restarts suddenly serial out shows Guru Meditation Error:

    @shiva-shankar Should be fixed. Should have been utime.ticks_add()

    Hi @robert-hh

    Utime.ticks_add() is defined already correct but i am getting the same error .. would it be firmware issue?



  • @shiva-shankar Should be fixed. Should have been utime.ticks_add()



  • @robert-hh
    Thanks for some suggestions...
    my firmware version 1.10.2.b1

    I tried your code..
    I am facing this error
    UDP recv Exception: 'module' object has no attribute 'ticks_add'

    node and gateway are not connecting since they get struck on the above error



  • @shiva-shankar I had that a lot too with my LoPy1 (never tested a different board with that). Since I updated the firmware to 1.17.3.b1, it is stable.
    Doing that, you have also to update the nanogateway software to use utime.ticks_cpu() instead of utime.tick_us(). In case you use the code form the nanogateway example, simply use the one from the library, or the copy I have here: https://github.com/robert-hh/pycom-libraries/blob/nanogateway/examples/lorawan-nano-gateway/nanogateway.py


 

Pycom on Twitter