Battery operation with fipy + pytrack

  • I'm trying to get a pytrack/fipy running on battery but it has trouble starting. Fine to keep it going once running but can't start when plugged in. It appears something is current limiting, Vin measures at 1.8 or so when battery is 3.9-4.2. Hitting reset doesn't help.

    I've seen comments about using lipo's for their current capability, I am using a generic Li-ion 26650 which is certainly capable of multiple amps (haven't measured draw yet) so that seems unlikely. Any suggestions ?

    Hardware schematics certainly would be useful to figure out what is going on.

    Update: I've tried the same with my pysense board, it starts fine with the battery so likely some difference between pytrack and pysense, maybe the GPS module needs 5V to start ? (though datasheet for it indicates not, max 29 mA@3v3)

  • its about 50uS. Forgot my camera today so no photo.

  • @tvetter1976 @enbis How long did the peak last in your measurement? Would that amount of energy maybe be storable in a low ESR capacitor to partly absorb the peak?

  • I tested current flow after waking from sleep with a scope. I found a current peak of 2.6A when Fipy was connected to pysense or pytrack and the go_to_sleep method was used. When I used deepsleep method from machine (pysense or pytrack still connected) , the current peak droped to about 1.4A. When I disconnected pysense/pytrack current peak was still at about 1.4A.

  • @niallp @Edward-Dimmack I have encountered the same problem as you, with your same devices. It seems that pytrack and fipy needs a peak current up to 1.8A to startup. I tested my devices with 2.4A USB power supply, then with 2 alkaline batteries with pull-up voltage board that provides 1.8A and everything works fine. After a few hours, I saw the board with a blinking green led on. It seems that the device could not boot and the blinking led was its feedback, so I measured the current and it was at 1.6A. The same configuration with a LoPy instead than the FiPy starts correctly. It seems that Pytrack and FiPy need a high peak current to startup. Maybe with Lipo batteries, I will solve the problem!?!?

  • @niallp I am having the same issue. Did you find out what the problem was?

    I tried 4.5v on the battery and it fired up straight away but not sure what the voltage range is for the pytrack. The documentation is not very detailed at all.

Log in to reply

Pycom on Twitter