Document for firmware upgrade?



  • Hi, all.

    I've downloaded new firmware (pycom_update_0.9.5.b1.tar.gz), and I try to find the document for this firmware, but I couldn't.

    If I extract tar, I can see two scripts, 'lopyupdate.py (python)' and 'update (bash)'.

    I tried to find further information about upgrading firmware, but I couldn't.

    How can I use this firware upgrading tools?

    • USB must be connected with LoPy (/dev/ttyUSB0)?
    • LoPy must be found 192.168.4.1 (via WiFi)?
    • G23 and GND on expansion board must be connected while upgrading?
    • Which script must be executed?

    Actually, I made two lopy bricks... three lopy remained... Please help me~



  • Thanks for all the info, glad you got everything working now.



  • Hi, all.

    I found the problem. In my case, It was VirtualBox USB driver problem.

    I'm using VirtualBox and I had been using USB 2.0 (EHCI) controller of VirtualBox.

    2.0 controller had made no problem with other applications yet. So, I couldn't suspect that.

    But, I changed USB 2.0 (EHCI) controller of VirtualBox to USB 3.0 (xHCI) controller.

    And then upgrading process is ended successfully. All bricked LoPys are resurrected.

    Thank!



  • Hi abilio, Thanks for reply.

    I tried bash script. but I made another LoPy brick...

    My steps are...

    1. Connect LoPy USB with computer, and checked /dev/ttyUSB0 is created.
    2. run pyupgrade/update bash script.
    3. Follow instructions.
      3.1. Turn off LoPy.
      3.2. Connect G23 with GND on expansion board.
      3.3. Turn on LoPy.
      3.4. Check LoPy USB is connected with computer again (/dev/ttyUSB0 checked).
      3.5. No WiFi connection. because while G23 and GND are connected, WiFi is not activated. No LED blinking.
      3.6. Select Country (LoRa frequency).
      3.7. 'Upgrading... Please be patient while the firmware is being uploaded to the board' message is seen.
      3.8. No next step, this message not ended... (waited up to 30 minutes, but no change)

    If I turn off LoPy at step 3.8, It doesn't work anymore, got bricked.
    I suspect USB communication fail (because no WiFi connection after step 3.3).
    Is there any USB communication test code before step 3.7 in pyupgrade/update script?

    Thanks. abilio.
    Any other tips?



  • Hi @nilbeing, I guess you're running the Unix upgrade tool. Try running the bash script. It will give you proper instructions on how to set up the board for proper upgrade. It should also fix the two LoPys that got bricked. Please post back any further results.


Log in to reply
 

Looks like your connection to Pycom Forum was lost, please wait while we try to reconnect.