[SOLVED] OTA Not Working



  • Hi all,

    I am trying to use OTA Wifi following the documentation, but when the device requests the manifest, an error ocurrs:

    File "OTA_server.py", line 156, in do_GET
        manifest = generate_manifest(current_ver, host)
      File "OTA_server.py", line 287, in generate_manifest
        to_delete, new_files, to_update = get_diff_list(current_ver, latest)
      File "OTA_server.py", line 215, in get_diff_list
        right_paths = get_all_paths(right, ignore=ignore)
      File "OTA_server.py", line 201, in get_all_paths
        paths += [os.path.join(d, f) for f in files]
      File "OTA_server.py", line 201, in <listcomp>
        paths += [os.path.join(d, f) for f in files]
      File "/usr/lib/python3.5/posixpath.py", line 89, in join
        genericpath._check_arg_types('join', a, *p)
      File "/usr/lib/python3.5/genericpath.py", line 143, in _check_arg_types
        (funcname, s.__class__.__name__)) from None
    TypeError: join() argument must be str or bytes, not 'NoneType'
    

    I have followed it and the problem seems to be that the method os.walk(path) returns None as dirpath. Am I doing something wrong?

    PD: The files inside the script folder are these:

    ServerFiles-->
                   OTA_Server.py
                   firmware_1.0.0.bin
                   firmware_1.0.1.bin
    

    Thanks,

    JuanMa



  • Problem solved. It is mandatory to create the version folders.


Log in to reply
 

Pycom on Twitter