WiPy v1.0 & LoPy not working with PyMate on iPhone 6s+



  • Hi,

    I have just downloaded PyMate on my iPhone 6S+ and followed the instructions on the YouTube video.

    I can login and PyMate 'downloads' files and all the other stuff as per video but when I go back to my router both the WiPy & LoPy start 'connecting' but don't and just 'timeout'.

    Are these devices supposed to use my router and access via this as opposed to using the 'built-in' access e.g. xxx.wlan.yyyy?

    I am confused as to what should be happening as nothing is happening, I have tried a few times now so just not sure at all.

    Any suggestions or advice please?

    Regards



  • Thank you.

    Not had chance to try stuff hope to have a play this weekend now thkngs are back to normal.



  • I realize this topic is old, but I had the same issue. It turned out to be that I was connected to the WiPy via FTP or Telnet (can't remember which). After disconnecting all sessions from the WiPy, it worked just fine.



  • @Roberto Thank you Roberto, I will try this. Also, I am a new to PyCom products although I have had the WiPy v1.0 for a while and now the LoPy plus pledged for the FiPy I have only just started to 'play' with the devices, so slow learn. Regards Ray



  • Hello @dartec,
    Yes, during the setup process a script is uploaded to your devices that allows them to connect to your router to gain internet access.

    After the setup all the messages between your phone and device go trough an MQTT Broker hosted by pycom.

    During the setup process make sure that you provide the app with the correct password for the router and that the router you selected works at 2.4Ghz.

    If you want you can redo the setup by putting your Pycom Device on safe boot (instructions here)
    https://docs.pycom.io/lopy/lopy/general.html#boot-modes-and-safe-boot

    and removing the jumper for the safe boot after the setup finishes.

    Not implying that you have the same problem as @NGorsline, but in his case it looks like the device can't access our servers, maybe the router name is wrong or the password.

    To check this on your device (connecting using FTP) you should see a file names boot.py. Here you will see your router name and password. Make sure that they are ok.

    As a side note: make sure your router has DHCP enabled and that its not doing MAC Address filtering. It is important that the device is able to access the internet.

    I will make some changes to the scripts so that they give a more comprehensive message and blink the LED in some specific ways to be more user friendly on errors detected. I will keep you posted with changes on this.

    Best,
    Roberto.



  • I am having the same issue, I have tried both the android and iOs.

    Here is the output from the LoPy right after resetting.

    rst:0x10 (RTCWDT_RTC_RESET),boot:0x13 (SPI_FAST_FLASH_BOOT)
    configsip: 0, SPIWP:0x00
    clk_drv:0x00,q_drv:0x00,d_drv:0x00,cs0_drv:0x00,hd_drv:0x00,wp_drv:0x00
    mode:QIO, clock div:2
    load:0x3fff9010,len:8
    load:0x3fff9018,len:312
    load:0x40078000,len:2348
    ho 0 tail 12 room 4
    load:0x4009f000,len:1364
    entry 0x4009f2f8
    rtc v112 Sep 26 2016 22:32:10
    XTAL 40M
    frc2_timer_task_hdl:3ffda948, prio:22, stack:2048
    tcpip_task_hdlxxx : 3ffdf114, prio:18,stack:2048
    phy_version: 123, Sep 13 2016, 20:01:58, 0
    pp_task_hdl : 3ffdfab8, prio:23, stack:8192
    mode : softAP(24:0a:c4:00:c1:53)
    dhcp server start:(ip: 192.168.4.1, mask: 255.255.255.0, gw: 192.168.4.1)
    dhcp server start:(ip: 192.168.4.1, mask: 255.255.255.0, gw: 192.168.4.1)
    mode : sta(24:0a:c4:00:c1:52)
    n:6 0, o:6 0, ap:255 255, sta:6 0, prof:6
    state: 0 -> 2 (b0)
    state: 2 -> 3 (0)
    state: 3 -> 5 (10)
    add 0

    connected with SkyNet, channel 6
    Traceback (most recent call last):
    File "boot.py", line 39, in <module>
    File "/flash/lib/pymate_basic.py", line 13, in <module>
    File "/flash/lib/pymate_library.py", line 402, in run
    File "/flash/lib/pymate_library.py", line 377, in _close
    File "/flash/lib/simple.py", line 109, in disconnect
    OSError: 128
    MicroPython v1.8.6-13-ge1a0670 on 2016-11-18; LoPy with ESP32
    Type "help()" for more information.


Log in to reply
 

Looks like your connection to Pycom Forum was lost, please wait while we try to reconnect.