New beta firmware updater 1.13.1.b2 - LORA MAC recovery, Linux support


  • administrators

    Beta Version 1.13.1.b2 is now available, including support for Linux.

    Here are the download links:

    Windows download
    MacOS download
    Linux downloads

    This version should improve reliability of the flash fs erase, fix a typo in the GUI and improve error handling. When using the GUI version, the server will now attempt to assign a new LORA MAC from a list of spares if the address on the server and on the device is either FFFFFFFFFFFFFFFF or 0000000000000000. This usually happens if a user has erased the device before flashing to with the online firmware updater for the first time. If you have any issues with this, please let me know.

    If you haven't already, please make sure to also read about the changes in 1.13.1.b1

    This is also the first public beta for the new binary firmware updater for Linux. The link for the downloads will bring you to a webpage with links to the actual packages. There are 3 types of packages available, and for each type there is a package with a 32bit and 64bit version.

    To check the version of GLIBC available on your system, please run ldd --version

    For users of Ubuntu 14.04 LTS and higher (and possible older versions and other Debian and compatible Linux versions with a GLIBC of at least 2.18) there are .deb packages available, which you can install either using sudo dpkg -i <pkg_name> or by double-clicking the file and installing it via the Software Package manager. You can start the GUI firmware updater via the Software menu or by running /usr/local/bin/pycom-fwtool from the command line. You can also run the CLI firmware updater with /usr/local/bin/pycom-fwtool-cli and the dialog based firmware updater with /usr/local/bin/pycom-update

    For all other Linux versions, there are two types available. One for Linux systems which have a GLIBC of at least 2.18, you will find three programs inside the pyupgrade folder after unpacking. pycom-fwtool is the GUI firmware updater and requires GLIBC 2.18. pycom-fwtool-cli [update:] requires GLIBC 2.14, which should be available on most Linux systems, so you should be able to use the dialog based updater pycom-update to flash the device.

    For systems which don't have GLIBC 2.18, there is a compatibility package available which requires [update:] GLIBC 2.14. The GUI version is a bit slow starting up so give it a minute, but it should still flash your board OK.

    Any feedback on your success with these is greatly appreciated.

    P.S. I forgot to mention that the cli firmware updater now has a -d / --debug option. This will output additional information that can be useful when trying out the new deployment options.

    Update: Further testing has shown that the compatibility version and the cli version both require GLIBC 2.14. I may be able to lower this further for the cli updater if anyone requires this so please let me know if you have a Linux system that can't run GLIBC 2.14


 

Pycom on Twitter