GPS error: (None, None) coordinates



  • Hello,

    I am using a Pytrack with my FiPy, and trying to get a location with the L76GNSS lib provided by Pycom.

    When getting coordinates, the method always gives me empty data, even after 20 minutes. I tried indoor and outdoor, always the same results.

    Is there some kind of initialisation that must be done before ?
    Does someone have the same issues ?

    Edit: I have two FiPy/Pytrack at my disposal and they both gives the same output.

    Thank's



  • Thank's for your replies !

    I though that the module couldn't catch signal for indoor, and this is why I tried outdoor. I had buildings around me but clear a view of sky for about 20 minutes and still no data.

    I've tried printing the frames, and I only get invalid data:

    '$GPGLL,,,,,000200.800,V,N*70\r\n'
    
    • V means invalid data,
    • N means no fix for GPS

    I started digging into the protocol specification for L76 device and saw multiple commands to configure it.
    Do you know some that may help getting better signal ? (I found Active Interference Cancellation for example, but it is activated by default).

    Thank's again !



  • Without any additional hard-/software?
    Have you tried to print the sentences read from the GPS chip?



  • Hi @fstaine

    GPS indoors will just not work and outdoors you need clear view of the sky.

    Perhaps that's the problem?


 

Pycom on Twitter