No file open to run



  • Hi guys, i have this error. I'm using atom to run code.
    I already uninstalled pymakr plugin, cleaned Atom cache and installed again but i have the error yet.
    Thanks!


  • Global Moderator

    @Bernal-R This issue has been solved in Pymakr v1.4.2, which was released today.


  • Global Moderator

    @dan I didn't realise this till now, but you're right. Clicking a file once makes it a 'preview', which is not detected as an open file by Pymakr. So for now, double clicking the file is the workaround. I'll try to find a way to add support for running 'preview' files.



  • Hi @Bernal-R and @RWall,

    For me, this only happens when you click on a file once and you haven't changed anything. This is because Atom opens the file as a "preview", so you can switch between files quickly without opening each one of them in a new tab. If you double-click on the file, it'll open it properly. You can also see whether a file is open or just previewed in the Title Bar, if the filename is in italics, it's just preview, otherwise open.

    Let me know if this helps!



  • @ralph - I just encountered this issue too. As you suggest, switching to a "different file" instead of the one we "want to run" works. However, this is a work-around instead of a solution to the issue. Is anything more known about this behavior? Thanks, Roger


  • Global Moderator

    Hey @Bernal-R, this feature should work, as long as you actually opened a .py file that you want to run. I have seen a glitch a long time ago where it wouldn't run, but that was solved by switching to a different file and than back to the one you want to run. Is that what's happening in your case?


 

Hello World?

Pylife on Kickstarter - November 2018








Back Us On Kickstarter >

Pycom on Twitter