Failed to connect (Connection refused) when connecting to 192.168.4.1 from Pymakr



  • I can no longer connect from Pymakr to any of my devices (Lopy4, Lopy, Sipy) through wifi (using the address 192.168.4.1). My laptop makes a wireless connection to the device (e.g. sipy-wlan-4597). And with PuTTY I can login to the device using telnet (with login "micro" and password "python"). But whenever I try to connect from Pymakr (within VScode), I get as reply "Failed to connect (Connection refused)". Connecting through USB (COM13) still works.
    I don't think there is anything wrong with the pymakr.conf file that looks as follows:

    {
        "address": "192.168.4.1",
        "username": "micro",
        "password": "python",
        "sync_folder": "",
        "open_on_start": true,
        "statusbar_buttons": [
            "console",
            "run",
            "upload",
            "download"
        ]
    }
    

    What to do to test where the problem is? It worked before. I don't see why it stopped working. I already reinstalled VScode and the pymakr pluging. It does not help.



  • @Ralph, thanks very much. It now works again.



  • @ralph It works. Thank you!


  • Global Moderator

    @jand @Ma This was indeed a bug in the latest release, where one of the classes wasn't updated to the latest version. I've just released v1.0.1 to fix this. let me know if the update does it for you!


  • Global Moderator

    Hi @jand, thanks for reporting. Your config seems to be good and I think this might be a bug in the plugin. I'll get back to you later today.



  • I've the some problem with my Wipy 2.0. It worked before, but today I can't connect from Pymakr. I tried to reinstal VScode and Pymakr.


 

Hello World?

Pylife on Kickstarter - November 2018








Back Us On Kickstarter >

Pycom on Twitter