VSCode Win10x64 Unusable



  • Hello.
    This is the first time I'm running PyMakr on Windows and it's not working out so well.
    Here is a recording of what happens when running a file: http://recordit.co/2yhc5AfoO8
    23 seconds in I reset the LoPy4 board manually on Expansion3.0. Using FW tool 1.15.2.b1.

    I also just tried Atom. Same issue in Atom.

    This morning I tried the same on OSX and it works fine so it's not the hardware or the cable: http://recordit.co/5cU1BkpD7J

    Tried a FiPY with dev firmware on a different expansion3.0. Broken on Windows.

    Tried a stock LoPy4 with release='1.0.0.b1', version='v1.8.6-237-g9d21f17 on 2016-12-15' over CP2102 and works fine on Windows. http://recordit.co/3IT3Q8SOPK

    Downgraded my dev LoPy4 to release='1.18.1.r1', version='v1.8.6-849-b0520f1 on 2018-08-29'. Broken on Windows.
    Downgraded some more to release='1.13.0.b1', version='v1.8.6-849-3d556fb on 2018-01-10'. Broken on Windows.

    Let me pull the stock LoPy4 and try it in the expansion board.
    Nope, same behavior on Windows with stock LoPy4 on expansion board.

    Now let me put the dev LoPy4 on CP2102.
    Ugh, well that didn't prove anything. Broken on Windows.

    Let me put the stock LoPy4 on CP2102 again.
    Yup, that works just fine.

    Conlusion:
    LoPy4 1.0.0.b1 over CP2102 works fine in VSCode.
    LoPy4 1.0.0.b1 on Expansion3.0 does not work in VSCode.
    LoPy4 1.19.0.b4 neither works over CP2102 or on Expansion 3.0 in VSCode.

    sysname='LoPy4', nodename='LoPy4', release='1.19.0.b4', version='v1.9.4-50f84dd on 2018-07-13', machine='LoPy4 with ESP32', lorawan='1.0.2', sigfox='1.0.1'
    
    Version: 1.27.2 (system setup)
    Commit: f46c4c469d6e6d8c46f268d1553c5dc4b475840f
    Date: 2018-09-12T16:17:45.060Z
    Electron: 2.0.7
    Chrome: 61.0.3163.100
    Node.js: 8.9.3
    V8: 6.1.534.41
    Architecture: x64
    


  • @dan issue persists with 1.0.3


  • administrators

    Hi @cmisztur,

    Thanks for the report, we're looking into it!


 

Hello World?

Pylife on Kickstarter - November 2018








Back Us On Kickstarter >

Pycom on Twitter