Unable to install Pymakr Package in Atom.



  • I sadly get an error when trying to install the Pymakr plugin for Atom 1.31.1, plugin version is 1.4.3.

    The following log is outputted along with the error:

    > serialport@6.2.2 install C:\Users\Mina\AppData\Local\Temp\apm-install-dir-118829-18352-19byhb3.v9uf\node_modules\pymakr\node_modules\serialport
    > prebuild-install || node-gyp rebuild
    
    
    C:\Users\Mina\AppData\Local\Temp\apm-install-dir-118829-18352-19byhb3.v9uf\node_modules\pymakr\node_modules\serialport>if not defined npm_config_node_gyp (node "C:\Users\Mina\AppData\Local\atom\app-1.31.1\resources\app\apm\node_modules\npm\node_modules\npm-lifecycle\node-gyp-bin\\..\..\node_modules\node-gyp\bin\node-gyp.js" rebuild )  else (node "C:\Users\Mina\AppData\Local\atom\app-1.31.1\resources\app\apm\bin\\..\node_modules\node-gyp\bin\node-gyp.js" rebuild ) 
    
    npm WARN deprecated crypto@1.0.1: This package is no longer supported. It's now a built-in Node module. If you've depended on crypto, you should switch to the one that's built-in.
    npm WARN deprecated parser-cctalk@1.0.2: reanmed to @serialport/parser-cctalk
    npm WARN deprecated parser-byte-length@1.0.2: renamed to @serialport/parser-byte-length
    npm WARN deprecated parser-readline@1.0.2: reanmed to @serialport/parser-readline
    npm WARN deprecated parser-delimiter@1.0.2: reanmed to @serialport/parser-delimiter
    npm WARN deprecated parser-ready@1.0.2: reanmed to @serialport/parser-ready
    npm WARN deprecated parser-regex@1.0.2: reanmed to @serialport/parser-regex
    prebuild-install WARN install No prebuilt binaries found (target=2.0.7 runtime=electron arch=x64 platform=win32)
    gyp info it worked if it ends with ok
    gyp verb cli [ 'C:\\Users\\Mina\\AppData\\Local\\atom\\app-1.31.1\\resources\\app\\apm\\bin\\node.exe',
    gyp verb cli   'C:\\Users\\Mina\\AppData\\Local\\atom\\app-1.31.1\\resources\\app\\apm\\node_modules\\node-gyp\\bin\\node-gyp.js',
    gyp verb cli   'rebuild' ]
    gyp info using node-gyp@3.4.0
    gyp info using node@8.9.3 | win32 | x64
    gyp verb command rebuild []
    gyp verb command clean []
    gyp verb clean removing "build" directory
    gyp verb command configure []
    gyp verb check python checking for Python executable "python2" in the PATH
    gyp verb `which` failed Error: not found: python2
    gyp verb `which` failed     at getNotFoundError (C:\Users\Mina\AppData\Local\atom\app-1.31.1\resources\app\apm\node_modules\which\which.js:13:12)
    gyp verb `which` failed     at F (C:\Users\Mina\AppData\Local\atom\app-1.31.1\resources\app\apm\node_modules\which\which.js:68:19)
    gyp verb `which` failed     at E (C:\Users\Mina\AppData\Local\atom\app-1.31.1\resources\app\apm\node_modules\which\which.js:80:29)
    gyp verb `which` failed     at C:\Users\Mina\AppData\Local\atom\app-1.31.1\resources\app\apm\node_modules\which\which.js:89:16
    gyp verb `which` failed     at C:\Users\Mina\AppData\Local\atom\app-1.31.1\resources\app\apm\node_modules\isexe\index.js:42:5
    gyp verb `which` failed     at C:\Users\Mina\AppData\Local\atom\app-1.31.1\resources\app\apm\node_modules\isexe\windows.js:36:5
    gyp verb `which` failed     at FSReqWrap.oncomplete (fs.js:152:21)
    gyp verb `which` failed  python2 { Error: not found: python2
    gyp verb `which` failed     at getNotFoundError (C:\Users\Mina\AppData\Local\atom\app-1.31.1\resources\app\apm\node_modules\which\which.js:13:12)
    gyp verb `which` failed     at F (C:\Users\Mina\AppData\Local\atom\app-1.31.1\resources\app\apm\node_modules\which\which.js:68:19)
    gyp verb `which` failed     at E (C:\Users\Mina\AppData\Local\atom\app-1.31.1\resources\app\apm\node_modules\which\which.js:80:29)
    gyp verb `which` failed     at C:\Users\Mina\AppData\Local\atom\app-1.31.1\resources\app\apm\node_modules\which\which.js:89:16
    gyp verb `which` failed     at C:\Users\Mina\AppData\Local\atom\app-1.31.1\resources\app\apm\node_modules\isexe\index.js:42:5
    gyp verb `which` failed     at C:\Users\Mina\AppData\Local\atom\app-1.31.1\resources\app\apm\node_modules\isexe\windows.js:36:5
    gyp verb `which` failed     at FSReqWrap.oncomplete (fs.js:152:21) code: 'ENOENT' }
    gyp verb check python checking for Python executable "python" in the PATH
    gyp verb `which` succeeded python C:\Users\Mina\AppData\Local\Programs\Python\Python37\python.EXE
    gyp verb check python version `C:\Users\Mina\AppData\Local\Programs\Python\Python37\python.EXE -c "import platform; print(platform.python_version());"` returned: "3.7.0\r\n"
    gyp ERR! configure error 
    gyp ERR! stack Error: Python executable "C:\Users\Mina\AppData\Local\Programs\Python\Python37\python.EXE" is v3.7.0, which is not supported by gyp.
    gyp ERR! stack You can pass the --python switch to point to Python >= v2.5.0 & < 3.0.0.
    gyp ERR! stack     at failPythonVersion (C:\Users\Mina\AppData\Local\atom\app-1.31.1\resources\app\apm\node_modules\node-gyp\lib\configure.js:454:14)
    gyp ERR! stack     at C:\Users\Mina\AppData\Local\atom\app-1.31.1\resources\app\apm\node_modules\node-gyp\lib\configure.js:443:9
    gyp ERR! stack     at ChildProcess.exithandler (child_process.js:267:7)
    gyp ERR! stack     at emitTwo (events.js:126:13)
    gyp ERR! stack     at ChildProcess.emit (events.js:214:7)
    gyp ERR! stack     at maybeClose (internal/child_process.js:925:16)
    gyp ERR! stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:209:5)
    gyp ERR! System Windows_NT 10.0.17134
    gyp ERR! command "C:\\Users\\Mina\\AppData\\Local\\atom\\app-1.31.1\\resources\\app\\apm\\bin\\node.exe" "C:\\Users\\Mina\\AppData\\Local\\atom\\app-1.31.1\\resources\\app\\apm\\node_modules\\node-gyp\\bin\\node-gyp.js" "rebuild"
    gyp ERR! cwd C:\Users\Mina\AppData\Local\Temp\apm-install-dir-118829-18352-19byhb3.v9uf\node_modules\pymakr\node_modules\serialport
    gyp ERR! node -v v8.9.3
    gyp ERR! node-gyp -v v3.4.0
    gyp ERR! not ok 
    npm WARN enoent ENOENT: no such file or directory, open 'C:\Users\Mina\AppData\Local\Temp\apm-install-dir-118829-18352-19byhb3.v9uf\package.json'
    npm WARN apm-install-dir-118829-18352-19byhb3.v9uf No description
    npm WARN apm-install-dir-118829-18352-19byhb3.v9uf No repository field.
    npm WARN apm-install-dir-118829-18352-19byhb3.v9uf No README data
    npm WARN apm-install-dir-118829-18352-19byhb3.v9uf No license field.
    
    npm ERR! code ELIFECYCLE
    npm ERR! errno 1
    npm ERR! serialport@6.2.2 install: `prebuild-install || node-gyp rebuild`
    npm ERR! Exit status 1
    npm ERR! 
    npm ERR! Failed at the serialport@6.2.2 install script.
    npm ERR! This is probably not a problem with npm. There is likely additional logging output above.
    
    npm ERR! A complete log of this run can be found in:
    npm ERR!     C:\Users\Mina\.atom\.apm\_logs\2018-09-29T13_42_17_290Z-debug.log```


  • @nickboots Have you tried Pymakr 1.4.4?



  • Hmm, seems like 1.4.3 is known to have issues, checked another PC where Pymakr is installed fine, and it turns out to be version 1.4.2.

    Any news on this?


 

Hello World?

Pylife on Kickstarter - November 2018








Back Us On Kickstarter >

Pycom on Twitter