Firmware release 1.0.0.b2

  • @arneme no matter how wrong things went, it's not broken for sure. The updater tool is able to program devices with a blank flash memory. You don't need to do a safe boot, simply use the updater tool to flash the latest firmware on it. On the failed update before some sections of the flash memory of your LoPy were erased and not programmed again, that's why it doesn't boot anymore, but the updater tool can fix it without any doubt.


  • @arneme
    try once again your upgrade - deselect "fast connection" or something simmillar in updater tool - it help me on one device maybe you got success also

  • @daniel Ah, modifying to run python2 explicitly works on a Pi3 running manjaro. Plugging into my laptop may have been easier, but I was curious.

    BLE scan can run repeatedly, and machine.reset() works for me. Thank you!

  • @daniel It looks like something went really wrong with the LoPy that I tried to upgrade earlier today without success. I am now not able to get in contact with it at all. The procedure for safe boot is not working (P12 to V3V and reset; does not result in orange blinking LED. The WiFi that is usually served by the LoPy is not present). Any ideas on how to fix this or is this LoPy gone forever?

    I have however successfully upgraded other LoPy devices (from home) to 1.0.0.b2.

  • @daniel I left my Linux PC at work but I can post the error message tomorrow. I tried the update tool on my Mac from my home network and that worked fine. Unless you changed something it seems to be the firewall at work that stops the necessary network traffic. I am therefore wondering how you are trying to serve the firmware?

  • @daniel I'm trying to update from a system that has Python 3.5.2:

    Traceback (most recent call last):
    File "./bin/", line 3, in <module>
    from esptool import ESP32ROM
    File "/root/pyupgrade/bin/", line 183
    print '%s' % inst.CHIP_NAME
    SyntaxError: Missing parentheses in call to 'print'

  • @arneme when the unix tool fails it normally prints a log with the errors it found. Could you copy and paste the log here? That should help find the problem... Thanks.

  • @daniel I did (and it did not work).

  • Could you try running the unix tool with sudo?

  • @daniel I am connected but I guess your server is not responding properly. On the Linux PC I get some sort of SSL error....

    As to firewall issues, that depends on what you are trying to do. Our firewall is open for everything going out but restricts access coming in. If you are trying to open a separate connection (and not piggybacking on the ongoing session) it will most certainly fail.

  • @arneme are you connected to the internet while you run the tool (and the tool needs to have the proper permissions...)? This new version fetches the binary from our servers every time you try to update the LoPy, as opposed to the previous tools which came bundled with the firmware binaries. This allows us to streamline the release process. Maybe it's a firewall issue... Could you check that?

  • @arneme I tried on Linux as well but it seems to be a problem with the "Fetching updates for this tool". On Linux I got a rotating spinner so it was easy to see that it did not manage to connect and download whatever it is looking for (on the Mac it only said "fetching updates for this tool" and I did not notice that it did not succeed). On both Linux and Mac I am however allowed to proceed (pushing the "next" button).

  • @arneme we can't reproduce the issue on our side yet, but we will continue investigating. Were you able to use the unix tool instead (that one also runs on OS X)?

  • @daniel Updated to 10.11.6 but same result :-(

  • @arneme, is there any chance you can update to 10.11.6 ? That's the oldest OS X version that we have tried with the latest update tool. Thanks.


  • @daniel I am running 10.11.5 (El Capitan). The other versions worked fine. I will try on my Linux PC.

  • @arneme that's very strange. It should let you select the country like with the previous versions. What version of OS X are you running?


  • @daniel This version of the upgrade tool (for Mac) will not let me choose a country in the "Country select" part of the wizard. Will I get 868 or 915 version then? Trying to upgrade failed however....

Log in to reply

Pycom on Twitter