Pymakr on VSCode does not detect missing remote directory



    1. create 'test' directory in local project
    2. sync project to WiPy
    3. rmdir 'test' directory
    4. sync again (upload)

    This should again create the 'test' directory on the Wipy. Instead I get
    Uploading project (main folder)...
    Not safe booting, disabled in settings
    Reading file status
    No files to upload
    Upload done, resetting board...

    After a format with os.mkfs upload works again. What's the problem here? Can I force an upload of a file or directory?


  • administrators

    Hi @Martinnn, empty folders are ignored when uploading. If you put a file in there, it'll upload it. Or you could create one via FTP on the device.


 

Hello World?

Pylife on Kickstarter - November 2018








Back Us On Kickstarter >

Pycom on Twitter