LTE modem stops to reply



  • 
    
    rst:0x1 (POWERON_RESET),boot:0x13 (SPI_FAST_FLASH_BOOT)
    configsip: 0, SPIWP:0xee
    clk_drv:0x00,q_drv:0x00,d_drv:0x00,cs0_drv:0x00,hd_drv:0x00,wp_drv:0x00
    mode:DIO, clock div:1
    load:0x3fff8028,len:8
    load:0x3fff8030,len:1728
    load:0x4009fa00,len:0
    load:0x4009fa00,len:14584
    entry 0x400a059c
    Pycom MicroPython 1.18.1.r1 [v1.8.6-849-b0520f1] on 2018-08-29; GPy with ESP32
    Type "help()" for more information.
    >>> from network import LTE
    >>>
    >>>
    >>> lte = LTE()
    >>>
    >>>
    >>>
    >>> lte.send_at_cmd('AT')
    '\r\nOK\r\n'
    >>> lte.attach()
    >>>
    >>>
    >>>
    >>> lte.is
    isattached      isconnected
    >>> lte.isattached()
    False
    >>>
    >>>
    >>>
    >>>
    >>> lte.isattached()
    False
    >>>
    >>>
    >>>
    >>> lte.isattached()
    False
    >>>
    >>>
    >>>
    >>> slte.e
    >>> lte.send_at_cmd('AT+CEREG?')
    '\r\n+CEREG: 2,2\r\n\r\nOK\r\n'
    >>>
    >>>
    >>> lte.send_at_cmd('AT+CEREG?')
    '\r\n+CEREG: 2,2\r\n\r\nOK\r\n'
    >>>
    >>>
    >>> lte.send_at_cmd('AT+CEREG?')
    '\r\n+CEREG: 2,2\r\n\r\nOK\r\n'
    >>>
    >>>
    >>>
    >>> lte.send_at_cmd('AT+CEREG?')
    '\r\n+CEREG: 2,2\r\n\r\nOK\r\n'
    >>>
    >>>
    >>>
    >>>
    >>>
    >>>
    >>>
    >>>
    >>>
    >>> lte.send_at_cmd('AT+CEREG?')
    '\r\n+CEREG: 2,2\r\n\r\nOK\r\n'
    >>>
    >>>
    >>> lte.send_at_cmd('AT+CEREG?')
    '\r\n+CEREG: 2,2\r\n\r\nOK\r\n'
    >>>
    >>>
    >>> lte.send_at_cmd('AT+CEREG?')
    '\r\n+CEREG: 2,2\r\n\r\nOK\r\n'
    >>>
    >>>
    >>>
    >>>
    >>>
    >>>
    >>>
    >>>
    >>>
    >>> lte.send_at_cmd('AT+CEREG?')
    '\r\n+CEREG: 2,2\r\n\r\nOK\r\n'
    >>>
    >>>
    >>> lte.send_at_cmd('AT!="ifconfig"')
    '\r\n    lo0\tLink HWaddrLen 0 HWaddr 00:00:00:00:00:00\r\n       \tUP MTU:0\r\n       \tinet Addr:127.0.0.1  Gw:127.0.0.1  Mask:255.0.0.0\r\n       \tinet6 Addr: ::1\r\n\r\nOK\r\n'
    >>> lte.send_at_cmd('AT+CEREG?')
    '\r\n+CEREG: 2,2\r\n\r\nOK\r\n'
    >>>
    >>>
    >>>
    >>>
    >>>
    >>>
    >>> lte.send_at_cmd('AT+CEREG?')
    '\r\n+CEREG: 2,2\r\n\r\nOK\r\n'
    >>>
    >>> lte.send_at_cmd('AT+CPIN?')
    '\r\n+CPIN: READY\r\n\r\nOK\r\n'
    >>> lte.send_at_cmd('AT+COPS?')
    '\r\n+COPS: 0\r\n\r\nOK\r\n'
    >>>
    >>>
    >>>
    >>> lte.send_at_cmd('AT+COPS=?')
    ''
    >>>
    >>>
    >>> lte.send_at_cmd('AT+CFUN=?')
    ''
    >>>
    >>> lte.send_at_cmd('AT+CFUN?')
    ''
    >>>
    >>>
    >>>
    >>>
    >>> lte.send_at_cmd('AT')
    ''
    >>> ets Jun  8 2016 00:22:57
    
    rst:0x1 (POWERON_RESET),boot:0x13 (SPI_FAST_FLASH_BOOT)
    configsip: 0, SPIWP:0xee
    clk_drv:0x00,q_drv:0x00,d_drv:0x00,cs0_drv:0x00,hd_drv:0x00,wp_drv:0x00
    mode:DIO, clock div:1
    load:0x3fff8028,len:8
    load:0x3fff8030,len:1728
    load:0x4009fa00,len:0
    load:0x4009fa00,len:14584
    entry 0x400a059c
    Pycom MicroPython 1.18.1.r1 [v1.8.6-849-b0520f1] on 2018-08-29; GPy with ESP32
    Type "help()" for more information.
    >>> from network import LTE
    >>> lte = LTE()
    

    and freeze there....

    SYSTEM VERSION

    FIRMWARE VERSION
    Bootloader0 : 5.1.1.0 [33080]
    Bootloader1 : 5.1.1.0 [38638]
    Bootloader2* : 6.0.0.0 [38729]
    NV Info : 1.1,0,0
    Software : 6.0.0.0 [38729] by robot-soft at 2018-08-23 15:18:03
    UE : 6.0.0.0
    COMPONENTS
    ZSP0 : 1.0.98-3150
    ZSP1 : 1.0.98-3140



  • You may be encountering issue mentioned here:
    https://github.com/pycom/pycom-micropython-sigfox/issues/225



  • @abrilevskiy AT+COPS=? can take a very long time to finish, longer than the 10 seconds the send_at_command waits for an answer. So if you wait a while, even several minutes, you'll back to normal response. Just use a single AT command for checking.


 

Hello World?

Pylife on Kickstarter - November 2018








Back Us On Kickstarter >

Pycom on Twitter