WiPy can`t get started

  • Hi all,

    I just received my WiPy 2.0 board and Im having trouble doing anything with it.

    1. So far I`ve only succeeded to login with pymakr on my mac. But the minute I do
      it stops working.

    2. Ftp(using FilZilla) sort of succeeds. I cant view the files inside the /flash.
      Screen and putty fails. Although when I reset the board when logged using screen. I see the initialization process but I still cant execute any code.

    3. All attempts at updating the firmware using the upgrader tool have failed both on my PC and my mac. (Yes, I connected G23 to GND)
      The error is,

    4. I tried using the esptool to manually update the firmware but I get an error
      A fatal error occurred : Failed to connect to esp32 : Timed out waiting for packet header

    5. When I try to use a COM port to connect to my WiPy using pymakr, it connects, then gives an error
      failed to initiate a friendly repl

  • @Knoahlr

    as @rskoniec wrote do the following - i have modified two points :

    1. Check if you have all jumpers on the expansion board
    2. Unconnect (USB) WiPy/LoPy board from PC.
    3. Connect wire G23+GND.
    4. Connect the board (USB) to PC by shortest usb cable.
    5. Upgrade but unselect fast connection in upgrade tool.
    6. after sucessfull update unconnect the board (USB) from PC.
    7. Remove G23+GND wire.
    8. Connect the board (USB) to PC.
    9. Check f/w release with os.uname()

    you can try also at point 4
    when you press upgrade button i upgrader tool or really shortly before
    press reset button on the board - this should work

  • @robert-hh Yes I did.

  • Did you connect GP23 and GND & Reset then? That's needed for upgrading via USB/Serial,

  • @robert-hh @livius I`m getting an error A fatal error occurred: Failed to connect to ESP32: Timed out waiting for packet header, whenever I try to use the Upgrader tool. Did any of you experience this problem. Do you think this a problem with my WiPy or the expansion board?

  • Flashing by uploading appimg.bin to /flash/sys does not work any more since V1.0.0.xxx (or so). You may use the uploader tool, or if you have built you own image, use
    make flash

  • @Knoahlr
    i also tried before by ftp but it does not work properly
    and somwhere in the formu some admin say that it is no longer supported
    but i am not sure

    to fix problem flash it by updater tool

  • @sakis Hey, I did this same exact steps a few times and all I was able to see was the output. Also, whenever I was connected to the board using Pymakr and screen at the same time. I could see the exact same output from Pymakr on the screen terminal.

    I tried to upgrade the firmware by ftp(ing) the binary file to /flash/sys but now when I reset the board I see a red light and it doesn`t seem to finish booting up.
    This what I see on my screen terminal

    rst:0x1 (POWERON_RESET),boot:0x13 (SPI_FAST_FLASH_BOOT)
    configsip: 0, SPIWP:0x00
    mode:QIO, clock div:2
    entry 0x4009f2d8

    Booting in safe mode doesn`t help.

  • @Knoahlr

    The screen connection stability is improved in every firmware update. Make sure that you are not using any other terminal multiplexers (e.g. tmux or screen inside screen). Open a new terminal window to ensure that there are no such dependencies and use screen /dev/yourdevice 115200.

    It might take some time before the REPL appears. If you still don't get it keep the screen connection open and press the reset button on your board.

  • @Knoahlr
    change usb cable ;-)

  • @livius Yes I do.

  • @Knoahlr
    check if you have all jumpers on the expansion board

  • @Ralph I got the WiFi and Ftp working, everything else fails. Especially the much needed firmware update.
    Also, when i connect to the board using screen (serial connection), I can only see the output but can`t type and send any commands to the board. Is this a problem with screen or my board.

  • @rskoniec Ive tried this, (atleast a thousand times). Still does`t work. Im still on firmware release 0.9.0.b
    Ive tried flashing the firmware using the esptool but I get an error, ** Failed to connect to ESP32: Timed out waiting for packet header**

  • hi @Knoahlr,

    You're already getting proper help here, but let me add a few points to keep in mind when getting started:

    1. If you are connected to the board over wifi and you set the network mode, it'll re-initialise the connection and it'll indeed lose connection. See this page for good wifi example scripts to prevent this

    2. Make sure you set Filezilla to use 1 connection at a time. See the docs for info. Using FTP, make sure you have the REPL code in the boot file and then try to attempt serial or telnet connections.

    3. and 4. Procedure of @rskoniec below should work. Try that first. It might also solve 5. giving the REPL code is in your boot file.

    I hope that helps, let us know if you get it to work.

  • @Knoahlr Here is my update procedure:

    1. Unconnect (USB) WiPy/LoPy board from PC.
    2. Connect wire G23+GND.
    3. Connect the board (USB) to PC.
    4. Upgrade.
    5. Unconnect the board (USB) from PC.
    6. Remove G23+GND wire.
    7. Connect the board (USB) to PC.
    8. Check f/w release with os.uname()

  • @Knoahlr
    it should be turned off(does not blink) when you connect G23+GND
    but as robert-hh say after that you must reset the board turn power off or press reset button

  • I'm almost sure, you did, but did you reset the board by pushing the little reset button after connecting G23 to GND?

  • Hi @livius,

    I`d tried this before several times, tried again now, the upgrade still fails. What colour should the LED light when I connect G23 to GND ?

  • try upgrade once again with disabled option "fast connection"
    and after successful upgrade look at os.uname() if it is newest
    but i have Windows only not mac

    instead putty i use Com Port Monitor from Arduino IDE
    and all work without any problem

Log in to reply

Pycom on Twitter