How to do a hard factory reset?



  • I have an import main in my boot.py file which seems to have caused me a lot of issues. I'm not familiar with micropython, so I read somewhere you need to import main.py into boot.py to fix it but it turned out it's not needed anymore with the new micropython versions.

    Currently I get the following with Pymakr:

    Connecting to a Pycom device
    Connected
    Error while communicating to a pycom device

    The following with rshell:

    Connecting to /dev/tty.usbserial-DQ008Y9O ...

    and if I try on boot directly with rshell or ampy I get:

    could not enter raw repl

    I tried to enter safeboot, rgb led flashed orange and it seems it worked, but with all that I get the same issue.

    All have the latest firmwares installed, and latest version of pymakr installed.

    One more thing that could've been the issue is that I was trying to power on 2 of the 3 lopys with 3.3v without the expansion, plugging them in VIN and GND. After I did that, serial stopped working.

    Given that I already posted, I'd like to mention the following, forgive me if i'm being a bit harsh.
    I decided to use my lopys today because the documentation was lacking months ago and it still does. I had to dig everywhere to see how to set up a lora gateway, it's the only reason I backed you guys. I don't a shit about the 3$ esp32 chip and BLE, the only single reason of backing you was for the lora gateway. I'm also pretty sure a lot here share the same point.
    To be honest, I really disliked what you did in your last move. You couldn't wait to finish all the missing documentation and updates needed for Lopy? rather than going for another kickstarter campaign (Fipy)? I didn't back you for this exact reason.

    Regards.



  • I managed to fix it now. I had to telnet to the ip, it was buggy as hell though, I had to keep pressing ctrl+c for couple of times until it finally worked and I soft factory erased it after. Nevertherless, you should mention how to do a hardware factory reset in the documentation.

    Now with the Lopy i'm trying as a nano gateway, the same code mentioned in a post on the forum, just printing ACK if it managed to connect to the gateway, it'll stop after few minutes for some unknown reasons.


Log in to reply
 

Looks like your connection to Pycom Forum was lost, please wait while we try to reconnect.