Expansion board 3.1 : Powering off LiPo



  • I'm struggling to get the to boot from when powered from a Lipo. My code and the Expansion board works fine when powered by USB. The battery is fully charged with a voltage of 4.1v. I've tried connecting P8 to 3.3v (as indicated in the pin out) to pull it high but that doesn't seem to make any difference...

    The LED comes on but that's it.

    Am I missing something obvious?



  • @pac_71 No. A Pull-Up resistor connected between P8 and 3.3 V dose not require extra action. At a value of 4.7k or 10k, some other units, the ESP32 or a logic output of an external device, can drive it low when needed. No switch is required. P8 is also used for the SD card. So connecting it directly to 3.3V would block the SD card.



  • @DomGiles I have the same problem with a Lopy4 & Expansionboard 3.1. It boots okay when powered from USB, works okay once USB is disconnected and operating on 3.7v Lipo but wont restart after reset on battery only.

    @robert-hh Thanks for the tip. I tried a direct jumper between P8 and 3.3V and only got flashing Orange/Power LED. I have some resistors on order now to try the pull down.

    For a poor mechanical engineer.

    A pull up means a resistor between the 3.3V pin and the P8 pin (as marked on the Expansion Board 3.1). You would then connect a switch between P8 and GND to pull it low when closed if you were using this as a logic circuit.

    Conversely, A pull down would be a similar resistor between P8 pin and GND. To make sure there is 0V at P8. You would then have a switch to 3.3V for a high when closed signal.



  • @robert-hh said in Expansion board 3.1 : Powering off LiPo:

    " (some nasty people call it a bug

    Still no luck. Tried 4.7k and 10k. Still won't start. Works fine when powered by a Adafruits power boost 500c to vin.

    I only have a few sensors hanging off the back as well... Shame. Feeling very underwhelmed by the testing that goes on some of the expansion boards. I would make the case that if you allow a battery to be attached to an expansion board, there's a reasonable expectation that it should be able to power it.

    Same with the sensor board. There's a reasonable expectation that a temperature sensor would measure the ambient temperature without having to worry the controller hadn't been running for a while etc. I'm going to have to give up on them. They feel like they all need another rev with some additional QC love and some decent documentation.



  • @domgiles This is a often mentioned "feature" (some nasty people call it a bug). Try to pull up P8 with a resistor of 4.7 to 10 k to 3.3V.



Pycom on Twitter