Pymakr not working with VSCode 1.31



  • Just upgraded VSCode, pymakr doesn't work - no REPL connection, no command bar although the plugin is loaded. Went back to 1.30 and pymakr works again.


  • Global Moderator

    @jpaul Good to hear. Our tutorials don't cover auto-connect very well yet, we'll work on that!



  • @jpaul Sorry for the bother. Issue was that autoconnect did not find right port. I changed that, but did not find any instructions to turn off autoconnect. Once I figured that out, all was well.



  • @jpaul said in Pymakr not working with VSCode 1.31:

    It makes no difference. Is this part of the bug above, or something different?

    In the good old Win7 64 bit times I had to deinstall the zadig dfu driver. But there was another driver. At best you browse this forum for it, if your problem is related to this driver. I use now a raspberry pi for dfu updates.


  • Global Moderator

    @jpaul Strange, if the comport manufacturer shows 'Pycom Ltd.', Pymakr should recognise that as a Pycom board and autoconnect. Not entirely sure why it doesn't, because it looks correct in your message.

    The alternative for autoconnect is using the address field, like you correctly did. But it only works after you disable the autoconnect in the global settings :) If you do that it will work.



  • Just trying to get started, Using Win 7, pymakr 1.0.6 and vscode 1.31. All I ever get is: Autoconnect: No PyCom boards found on USB
    I am using Win 7, have the drivers installed, when I l do 'list serial ports' I see COM49 (Pycom Ltd).
    I have the lastest (win32) version of node.js.

    I have tried manually editing pymakr.conf and pymakr.json to say
    "address": "COM49"

    It makes no difference. Is this part of the bug above, or something different?


  • Global Moderator

    Hi @Martinnn, this morning we released a new version of pymakr (v1.0.6) that's compatible with vscode 1.31. Sorry for the inconvenience, but I'd recommend to update to vscode v1.31 and pymakr 1.0.6 :)


 

Pycom on Twitter