Update to Pybytes firmware 1.18.2.r3 (solving device WiFi connectivity issues)

  • Hi,
    we released new Pybytes firmware 1.18.2.r3 which is solving WiFi connectivity issues:

    • the device becomes disconnected after several days.
    • the device won't re-connect to a WiFi network if WiFi access point was powered off at the time when the device booted up.
    • much stable WiFi geolocation

    Now in Pybytes library, a watchdog timer is being fed after a device receives a pong response from pybytes (device sends a ping message on WiFi every 10 minutes).

    If you have a device in a field which appears offline in Pybytes, now within 10 minutes it should be back online.

    Because of a bug in Pybytes library there's a chance that your device will not automatically reboot after a successful WiFi OTA firmware update. Please reboot your device manually. We will make OTA updates more robust in the future.

  • @eric-waai I tried twice in our office, my device got successfully updated from 1.18.2.r0 -> 1.18.2.r2

  • i found out it actually didn't updated the firmware

    when i tried OTA again the device got stuck
    after a manual reset i get a checksum error

    Performing OTA
    Requesting: manifest.json?current_ver=1.18.2&sysname=FiPy&wmac=807d3ac263a8 to software.pycom.io:443 with SSL? True
    Wrapping socket
    Sending request
    Requesting: downloads/appimg/firmware_FiPy_1.18.2.r2.bin to software.pycom.io:443 with SSL? True
    Wrapping socket
    Sending request
    7 [0]
    8 [0]
    9 [64]
    <0>ets Jun 8 2016 00:22:57

    rst:0x1 (POWERON_RESET),boot:0x16 (SPI_FAST_FLASH_BOOT)
    configsip: 0, SPIWP:0xee
    mode:DIO, clock div:1
    entry 0x400a059c
    E (439) esp_image: Checksum failed. Calculated 0x1d read 0x67 # checksum error over here
    WMAC: 807D3AC263A8
    Firmware: 1.18.2
    Pybytes: 0.9.6

  • Hi, @eric-waai thank you for reporting this bug. I was able to replicate it, it seems to me too that the device remains connected to Pybytes. So probably there's just some edge case we need to fix to not throw this error after doing OTA.

  • Error receiving MQTT. Ignore this message if you disconnected
    Traceback (most recent call last):
    File "_pybytes_protocol.py", line 93, in __check_mqtt_message
    File "_mqtt.py", line 58, in check_msg
    File "_mqtt.py", line 56, in check_msg
    File "_mqtt_core.py", line 229, in check_msg
    File "_mqtt_core.py", line 216, in wait_msg
    File "_pybytes_protocol.py", line 123, in __recv_mqtt
    File "_pybytes_protocol.py", line 161, in __process_recv_message
    NameError: name 'machine' is not defined

    got this after updating the firmware via pybytes

    it did reconnect successful

  • Hi @Steve-Williams,

    firmware 1.18.2.r2 is now publicly available.
    You have two ways how to update your firmware:

    1. With Pycom firmware updater app:

      1. create new activation token for your device In Pybytes (device -> configuration)
      2. in firmware updater check "force update pybytes registration" and paste your new activation token
    2. WiFi OTA firmware update with Pybytes:

      • In pybytes go to your device -> settings - firmware

  • @jirkakrepl Will this be available automatically using the Pycom Firmware Updater or does it have to be downloaded from somewhere?

    I am having some WiFi connection issues so would be keen to try this, provided it doesn't introduce other issues..

Log in to reply

Pycom on Twitter