Opening workspace corrupted Pymakr, now it won't load in VSCode

  • I had issues with pymakr in VSCode on my Ubuntu machine, so I thought i'd try loading it on Windows 10 64 bit.
    VSCode loaded fine, but I used the latest version 1.31. I then added Pymakr plugin and it seemed to load correctly. I then tried to copy in and add the workspace I was using in Ubuntu. When I did that, pymakr did the same thing it is doing on my Ubuntu machine.. at the bottom status bar, each of the Pymakr options is displayed twice. Neither of them works to connect to my devices.
    I did some searching and found posts saying that VSCode 1.31 is buggy but 1.30 should work, and followed the instructions to remove the folders it added. After installing 1.30.2 and installing Pymakr plugin 1.0.6 again, I don't see any of the Pymakr options in the status bar. There's no menu item anywhere to check Global Settings. I've tried to remove and reinstall Pymakr and VSCode 1.30.2. How can I troubleshoot this?

    Also, what to do about my Ubuntu machine? I've tried removing pymakr plugin from it and reinstalling, but there's still two instances of each menu item for Pymakr..

Log in to reply

Pycom on Twitter