WiPy 2.0 Firmware Help

  • Hey guys, really excited about python on ESP32. I dont have a wipy yet, so I'm trying to boot the firmware on devkitc. I can boot and connect to the softap but can't connect via telnet or ftp. I'm guessing something is missing like a partition table entry for filesystem space? Could you give me a hint? Thanks.

  • Fringe benefit of the flash bug & full update means I can now run the wipy firmware successfully on the devkitc board, just had to change to dio flash mode.

  • @daniel My Wipy2's are now updated fine - now have a problem with one of my two LoPy's, one updates and the other won't (tried Windows and OSX). Can't find a binary image of the firmware.so am a bit stuck! I believe there is away to fix it using my Expansion board.

  • Just download the updater from: https://www.pycom.io/support/supportdownloads/ under the firmware updates section. If you haven't put any scripts on your WiPy don't bother about the safe boot thing. Simply make sure that your computer is connected to the WiPy WiFi network before starting the update process. What kind of error do you get? Which version of the updater are you using (Windows, OS X, linux)?


  • Where can I find the latest version of firmware for WiPy 2. Mine arrived this morning and a label on the box said that I should update the firmware before use. Where is the latest firmware? I tried the standalone updater but that failed maybe because I did not know when to disconnect the link wire and the instructions say click 'next' but I only ever see 'continue'. Have looked on the Pycom site as well as the Micropython site but not clear as to when I remove the link wire during the booting process.

  • Understandable... Not expecting bug free operation or working ota upgrades, just minimum viable config to try before buy. If the fs partition is there won't the firmware format and create it to default? Or needs to be factory flashed?

  • Hello,

    Well, you are missing the file system, and the bootloader, among other things... We really don't support running our firmware on third party boards.


Log in to reply

Pycom on Twitter