L01 OEM module not working with SD card

  • Hi guys,

    I am currently trying to integrate an L01 OEM module with an accelerometer and an SD card for logging, however the SD card I am using refuses to work on the OEM - throws a OSError: the requested operation failed.

    I tried the same card on an Expansion board 3 with a LoPy and it works absolutely fine. I've triple checked my connections and everything looks good, I even tried experimenting by pulling the data lines up with 10K resistors and still nothing. I get the error after running sd = SD().

    I even tracked down the pin connections on the expansion board with a multimeter and they are exactly the same as my custom PCB.
    Below is my schematic. I'm following the pins from the official docs - https://docs.pycom.io/firmwareapi/pycom/machine/sd.html
    Wasn't sure what to do with CS so I added a connection just in case.

    Any help is very much appreciated!

    0_1552062185003_Screenshot 2019-03-08 at 16.09.18.png 1_1552062185004_Screenshot 2019-03-08 at 16.09.32.png

  • After firmware update this problem vanished in my case.

  • I have exactely the same issue with a W01 OEM module. Used WiPy3 before. Cannot mount the SD card, although it works perfectly fine with WiPy3. Has this been solved?

  • @robert-hh thanks for the reply. I can't get my head over why it's not working however I will try with the caps, who knows...

  • I made a homebrew board with extactly these connections for the SD card, and it works. CS is not required and is in my case floating. I added a 100µF capacitor close to the SD card at the board between Vcc and GND, just to be sure, but I am not sure whether it is needed.

Log in to reply

Pycom on Twitter