visual studio code 1.32.1 (mac) - how to set python version ?

  • VSC 1.32.1 on a mac + expansion board + fipy connected.
    Everything seems to work.
    REPL works, using Filezilla works. Firmware update worked.
    Now I wrote a little program, saved it on my mac - desktop.
    When I run it with the "run"-button at the bottom, I get errors in the way like it doesn't understand python3.
    When I run it in the terminal with python3, program works.
    Which interpreter is used when you use the "run"-button ?
    Can you set the python version ? ( global/workspace)

    I'm just starting with MicroPython + VSC + pymakr, looked at the documentation on github, but didn't find anything.
    Is there more documentation elsewhere ?

    Googled, found something to search for 'select python interpreter' in the command palette ( cmd+shift+p), but that is not
    working with me. In the command palette I see only pymakr commands for this workspace.


  • @reidfo
    Thanx, clear to me now.
    And there are different micropythons ( board specific ), most differences hardware related.
    When you use libraries, you don't have to upload them immediately to the board, using the 'run' button.

    By "See the pycom docs" you mean I suppose.
    The problem I have ( and I also had with finding hardware info ), when starting with Google to find a topic, I am sometimes directed to other older documentation ( also by pycom ). So I sometimes get lost between the versions.

  • Pymakr connects to your Pycom module (FiPy in your case) to upload and run code on the device. When you click Run, Pymakr is uploading the code to the FiPy, and the FiPy runs your code. It does not use the Python interpreter on your PC, rather Pycom's micropython implementation on the FiPy is running the code. See the pycom docs for what commands and libraries are available.

Log in to reply

Pycom on Twitter