New Release candidate v1.20.0.rc9

  • Hello everyone, There is a new Firmware release candidate v1.20.0.rc9 released today the new release includes the following:


    • Releasing GIL when ssl handshake is performed.
    • Allow PDN list update when carrier is defined in LTE
    • Add support for LTE modem responses greater than UART buff size
    • Added Check for LTE band support against both SW and HW versions of the LTE modem.
    • Updated Sqns upgrade scripts to v1.2.5

    Bug Fixes:

    • Enabling Access to 2nd SPI perf for GPY modules
    • Use Hardware timers for Lora timer tick to fix RTOS timer drifts when cache is disabled.
    • Updated OTA fixing failing OTAs after switching to Factory Partition.
    • Fix crash when pin ISR handler fires (i.e. LoRa TX done) during flash operation PR #278 by Martijn Thé @martijnthe
    • Remove defaulting of wifi max_tx_pwr to level 20 in init()
    • modlora: Reverted the rx spread factor in stats

    You can download the source code here
    or you can flash it directly via the Firmware Updater tool as the latest development firmware.

    Also new Sequans Firmwares for CAT-M1 [41065] and NB-IoT [41019] are available for download see this post

    NOTE: To upgrade to the New Sequans Firmwares 41065 and 41019 you should use the latest this latest Development release or the latest Stable release v1.18.2.r4

  • @tlanier
    Found the answer to my question. If I select the stable version in the Firmware Upgrade Tool and then select the Type/Version to development, I get the option to select 1.20.0.rc9.

  • Where can I get the GPy-1.20.0.rc9.tar.gz file? The file is not found on the downloads web page Downloads GPy.

    We have done extensive testing of our product with this version and have shipped production units. Now we have purchased new GPy's and when I try to use the Firmware Update Tool version 1.15.2.b1 with development releases checked, the 1.20.0.rc9 option is not available.

    Any help would be appreciated. We will update and test our program to work with newer releases later, but for now we need to use the well tested version. I know it was a beta version, but for our purposes it worked well. The production version at the time had issues which the beta version solved.

  • The iccid() function only works after an attach command is attempted. Since we use the ICCID to determine the correct APN to use in the attach command, we have to do a dummy attach call, read the iccid, detach, and then correctly attach with the computed apn. Hope this helps others until this issue is resolved.

    Below is the revised code that now works.

    from network import LTE
    lte = LTE()
    iccid = lte.iccid()    # does not work
    lte.attach(apn='unknown')    # attempt attach so iccid() will work
    iccid = lte.iccid()    # iccid() now works
    # compute apn from iccid
    lte.attach(apn=computed_apn)    # attach  with correct apn

Log in to reply

Pycom on Twitter