No DFU capable USB device available.

  • There are some similar threads here on the forum but none seem to resolve the issue that I have.

    I'm using a Pysense board with a SiPy module. When I initially receive these components, I was able to update the firmware without issue. Recently the Pysense and SiPy stopped sending data to Sigfox from the code I'd written. I checked the REPL in Atom to see what was happening and the response from the library was that the Pysense board could not be detected.

    I decided to redo the firmware as per these instructions, but Zadig doesn't see the Pysense board in DFU mode, even though Device Manager shows it as COM(x). If I just try to update the firmware by dfu_util_static.exe -D pysense_0.0.0.8.dfu from the command line I get "No DFU capable USB device available"

    I've tried removing the Pysense (COM(x)) from Device Manager and starting again but no luck.

    Any suggestions as to what is going on would be appreciated.

  • @SiMoS-IoT Haven't done it in a while, but timing is tricky. You need to press and hold the button while you connect the USB (much easier to connect the USB on the computer side than on the device side), release the button (don't remember if timing on that is sensitive or not), wait a second or two, and start the DFU utility (you should have the command line ready and just have to press enter).

    If you do it too early the device will not have been recognised by the OS yet. If you do it too late it will have exited DFU mode.

  • @jcaron Just tried it again this morning. Pressed the button as hard as I could and did a 3 count and it worked. Left it for about 10 minutes and tried it again exactly the same...second time it didn't work, so I'm not sure what's going on.

    Upshot is that the unit is working correctly again.

  • @SiMoS-IoT Do you correctly press the button on the Pysense when you connect it, and start dfu_util within the 7-second window?

    Timing can be tricky to achieve, but once you've got the hand of it it should be pretty easy.

  • Yes...tried both of those.

    I have two other SiPy's, another Pysense and an Expansion Board problems with any configuration with those components if I load Zadig.

    I have also changed the SiPy module to the other Pysense and it works fine, so it narrows it done to the Pysense board itself.

    Just need to get it back to Factory Default and see if it will reinstall the firmware.

  • @SiMoS-IoT At the risk of asking a silly question: did you try to use a different USB cable or PC USB port?

Log in to reply

Pycom on Twitter