LoPy connection error via pymakr and pycom upgrade

  • I have recently gotten my LoPy4 with Pysense expansion board and have been successfully working with it.
    However, at some point I messed up a program and had to do a safe reboot. Since then nothing really works anymore. When I connect the LoPy via USB it is clearly found, e.g. using lsusbin terminal I see:

    Bus 001 Device 022: ID 04d8:f012 Microchip Technology, Inc. 

    The same is true for Pymakr in Atom. However, after automatically trying to establish a connection I get the error:

    Searching for PyCom boards on serial...
    Connecting to /dev/ttyACM0...
    Connection error: Error: timeout

    Nothing I've tried so far solved that problem. I also don't seem to get into safe boot. If I try to use the Pycom Upgrade Software I get the following error at the end:
    Error message in Pycom Upgrade
    Can I somehow do a hard reset or something?

    Thank you already in advance!


  • Update: I managed to get the device to do a hard reset and select the factory firmware by connecting P12+3v3 for 7-9 seconds. The LED flashed green, flashed green faster and then again green very fast. Afterwards, I disconnected the device. However, I still get the same connection error: Error: timeout.
    What is different now, is that I can run the Pycom Upgrade tool and it detects the device and performs an update: Update results
    But even afterwards: I can't access the device via Pymakr due to the same error.

    Has anybody another idea what I could do now?

    Best, Felix

Log in to reply

Pycom on Twitter