Pymakr 1.1.2 VSC can't connect to lopy4 through Wifi?



  • I can make it work with USB and I can connect with putty or my FTP browser over Wifi but I can't connect in VSC (windows)?
    boot.py and main.py are empty
    project settings file:

    {
    	"address": "192.168.4.1",
    	"username": "micro",
    	"password": "python",
    	"sync_folder": "",
    	"open_on_start": true,
    }
    

    global file:

    {
    	"address": "192.168.4.1",
    	"username": "micro",
    	"password": "python",
    	"sync_folder": "",
    	"open_on_start": true,
    	"safe_boot_on_upload": false,
    	"py_ignore": [],
    	"fast_upload": false,
    	"sync_file_types": "py,txt,log,json,xml,html,js,css,mpy",
    	"ctrl_c_on_connect": false,
    	"sync_all_file_types": false,
    	"auto_connect": true,
    	"autoconnect_comport_manufacturers": [
    		"Pycom",
    		"Pycom Ltd.",
    		"FTDI",
    		"Microsoft",
    		"Microchip Technology, Inc."
    
    	]
    }
    

  • Global Moderator

    @KenM Yes I agree it's not very intuitive, I will improve the help text a little. The new Pymakr 2.0 we're working on (for atom) will have some good solutions, which we'll also build in to vscode after it's completed.



  • Thanks, Indeed that was the mistake, now it works.
    I was confused with the global setting and project setting which didn't make it clear what was used and what not.
    Maybe just change the help text to: Edit global settings file:
    "auto_connect": false for Wifi
    "auto_connect": true for USB


  • Global Moderator

    HI @KenM, can you tell me what the terminal output is when trying to connect over Wifi? Do you get a connection refused message?
    FYI to actually connect over wifi instead of com, you need to disable auto_connect in global settings, which will always try to connect on USB and will ignore the address setting (as noted in the terminal output)


Log in to reply
 

Pycom on Twitter