Modem only registers via VSCode

  • Hello,

    I am using an AT&T SIM with the LTE-M service. When I run my simple app from Visual Studio Code, which posts data via https, everything works perfectly. If I attempt to reset the device and allow it to run the app via the, it never registers with the cellular network (AT+CEREG? always comes back with "0"). However, if I interrupt the app with ctrl+c and run it from VSCode it succeeds (pymrk > Run current file). The app runs successfully 100% of the time with VSCode and 0% of the time after a reset.

    Thank you,

  • System details:
    GPy with firmware version 1.18.2.r7
    Your modem is in application mode. Here is the current version:

  • I found that the modem was in an invalid state after the unit rebooted. When I sent an "AT+COPS=?" command to the modem it would respond with "ERROR" or "+SHUTDOWN." So, I updated my app to reset the modem before I attempted to connect to the LTE network (AT^RESET). Now, I can connect to the network every time, regardless of how I run the file.

    • Could I have faulty hardware?
    • How long does it take for the Sequans modem to initialize after boot?
    • The modem reset and associated testing as increased my transactions to ~45s each. Is this reasonable based on other users' experience?


Log in to reply

Pycom on Twitter