Pymkr "Syncing failed!"

  • Pybytes Beta

    Hi all,
    I use the last release of Pymakr ( 1.0.0.b8 ) but 99/100 the syncing fail!
    What's the reason ?
    What's the solution ?
    I'm on Windows7 - 64 bits and the Pycom board is WiPy2

    Thanks for help

  • @bvincent You can use the adafruit ampy tool, which allows to upload files through USB.

  • I am having the same problem
    LoPy FW 1.6.9.b1
    Pymakr 1.0.0.b8
    Syncing fails. Using the lorawan-nano-gateway files from GitHub. Main and Config go through but it chokes on nanogateway. It shows size 0 on /flash
    Tried using the latest version of Filezilla 3.25.1 and followed the instructions from the tools and features page.

    It connects correctly and gives a directory listing OK. I deleted the stub nanogateway file. When I attempted to upload it again FZ reports "Connection established, waiting for welcome message..." and then timesout endlessly

  • I found a partial solution to this problem, it happened the same to me with the LoPy.

    The console always showed me:
    "Syncing the project with the LoPy. Please wait...
    Syncing failed!"
    when I tried to load the Python scripts ino the LoPy.

    The solution I found was using a FTP to load the files.
    Section 2.4 from this page shows you how to configure the FTP settings to be able to do so:
    I used FileZila client and worked perfectly.
    Make sure you connect to the LoPy WiFi to load the files with the FTP.
    "Connect your computer to the WiFi network named after your board (e.g. lopy-wlan-xxxx, wipy-wlan-xxxx). The password is"

    I could not make it work through the Pymakr but at least in this way I was able to load everything into the LoPy with no problems.

  • Sync never worked for me (WIN7)

  • Hi all,
    Waiting next release, as a workaround, is there any possibility to write a file on the LoPy filesystem directly with USB/serial cable (I can't use Wifi/Ftp) ?

  • Pybytes Beta

    @gertjanvanhethof Do it but nothing change!
    also do: gc.mem_free() and the answer is "47584"

    Waiting the next release of the firmware ( perhaps the problem is fixed ? )

  • Pybytes Beta

    It seems to me that it's caused by less memory.
    You should stop the xPy for program running.
    Sometimes it helps to clear memory with:

    Reset REPL and run these commands:

    import gc

  • @livius I too have the same problem....after the new firmware update

  • Pybytes Beta

    Sync is working much better after updating to firmware 1.4.0.b1 and PyMakr 1.0.0.b8.
    For small projects it's better for large projects still lots of problems.

    From my experience you can only sync when you have REPL access and the LoPy is not running any code. So you have to stop it using a ^C in the REPL window.
    Sometimes sync is working fine after that but most often it's not.
    So I do:

    import os

    Reboot the LoPy and sometimes I have to reopen PyMakr again.

  • @Jiemde
    i have same problem with transmitting by ftp
    it is strange..

  • Pybytes Beta

    Hi All,
    Beleiving that problem was solve with the new firmware release, because each time I use the "sync" button the answer is " synced successfully ! " but unfortunately that work only 1 time ! and unfortunately with errors !
    example: 1 line of my dev is:
    i2c.writeto(I2C_ADDRESS, bytearray([0, SET_PRECHARGE, 0xF1])) what I read in the file is:
    2C_ADDRESS, dytearray([0, SET_PRECHARGE, 0xF1]))
    So some characters was not transmit and the word "bytearray" is changing in "dytearray" ?????
    Is it a problem in Pymkr or Windows or WiPy2 ?

    With Filezilla transfer it's the same !

    Thanks for solution if there is one !


  • Pybytes Beta

    @Ralph Sync is working when you flash memory to factory, close and open PyMakr again, reset the LoPy and make sure it's connected. Open the project and sync. It's working ones then.

  • Thanks for explaining the issue and I look forward to the update.
    Pycom is giving a sterling effort with their rate of progress.

  • Hi @Jiemde, @Shaun

    This has been a problem since the latest firmware updates. It has to do with some issues with low RAM on the board. Our embedded people are now working on that. Keep an eye out for the release notes of the upcoming firmware updates for the solution. Sorry for this inconvenience.


  • I too experience unreliable syncing using Pymakr and LoPy.
    OS = Win7 Prof, 32bit
    Sync seldom works.
    Mostly hangs or fails.
    Occasionally works after restarting Pymakr.

Log in to reply

Pycom on Twitter