Checking regional LoRaWAN settings



  • (1) Is there a way to query the existing LoRaWAN configuration? e.g. lora.init()

    We would like to know;

    • The channel setup - channel number, frequency, data rate.
    • Basically every setting in that would be part of the lora.init(, , , )

    I have tried to change the channel configuration with no success. Such as: lora.remove_channel(channel) for all, then lora.add_channel(..) => which generates TypeError: extra positional arguments given.

    Also, strangely lora.has_joined() will return "false" for OTAA, but always returns "true" for ABP. Possible bug.

    I have flashed the newer firmware 1.0.0.b3 and setup as Australian configuration, but I cannot seem to get the LoPy to join my network.
    I have switched the network to Sub-Band 2 [ch8-16], same as the TTN settings.
    I have switched back to Sub-Band 1 [ch0-7].

    I have tried OTAA and ABP without success.

    Has anyone successfully tried and used the LoPy in Australia?

    *We are currently using the Kerlink with Loriot platform, until our other GW's arrive, or TTN gateway get delivered.



  • @iotoz I've ordered 3 pairs and waiting to be delivered to some time this week. I don't have a Gateway yet. I want to use the LoPy as Nano Gateway. I hope I can get it working.



  • @iotoz

    Don't add_channel and remove_channel work? I think they didn't in 1.0.0.b3 but should do on the latest updates.

    From https://github.com/pycom/pycom-micropython-sigfox/blob/master/lib/lora/mac/LoRaMac-definitions.h (this is an open source project after all you're free to have a look ;-) the LoPy uses the 3 default channels if USE_BAND_868 is set.

    • LoRaMac default channels
      // Channel = { Frequency [Hz], { ( ( DrMax << 4 ) | DrMin ) }, Band }
      #define LC1 { 868100000, { ( ( DR_5 << 4 ) | DR_0 ) }, 1 }
      #define LC2 { 868300000, { ( ( DR_5 << 4 ) | DR_0 ) }, 1 }
      #define LC3 { 868500000, { ( ( DR_5 << 4 ) | DR_0 ) }, 1 }


  • @Turson
    Unfortunately I have had no reply to this issue, and it still remains a problem. I am aware of several members of Makerspace run in one of our main cities who have also had the same issue. They have reportedly crushed the LoPy and thrown it in the bin.

    I believe the problem is solvable, but haven't had the time to follow it up.

    Would be interested in anyone else's experience, and the specific steps taken.



  • I've been waiting for someone to reply to this inquiry? Is it resolved?



  • This is what I wanted to ask also. I'm in Europe but to get all actual LoRaWAN settings (ok, not the encryption keys) are is important.


Log in to reply
 

Looks like your connection to Pycom Forum was lost, please wait while we try to reconnect.