Error - Could not enter friendly repl



  • Hi, I synced some example code to my new LoPys to communicate between them and now when I try and connect to one of the LoPys on Pymakr I just get the error - 'Could not enter friendly repl'. The only way I can get this to disappear is to power up my second LoPy so that they are communicating, at which point the LED on the LoPy connected to my laptop goes solid blue and I get the >>>. However if I try to sync a new project it just freezes.



  • @soren
    lpss-serial2 is definitely not the Pycom device, it's an internal device part of the 2016 MacBook Pros, so your Mac isn't really picking up the Expansion board

    Have you tried restarting you Mac before connecting? Sometimes there are USB issues where the port seems to go "deaf" to new devices. Also recommend you try a different microUSB cable just in case

    I guarantee the LoPy works on a Mac - thats what I use - you just need to fix whatever issue is causing it not to see the expansion board


  • administrators

    @soren have you had issues with other development kits? That all sounds correct - so I'm thinking it might be a Mac OS driver issue.

    Did you install external FTDI drivers previously?



  • @bucknall It does indeed.
    I'm using the expansion board yes, and all jumpers are connected firmly. I'm using a samsong usb cable that I normally use for android development on a phone, so I would definitely expect that it's not a charge-only usb cable


  • administrators

    @soren Hmm this sounds like your LoPy is not being recognised over the Serial bus.

    Are you using the expansion board? If so, can you check to see if all of the headers (TX, RTS, RX, etc.) are connected?



  • @bucknall thank you for the quick reply, that's very appreciated.

    when running ls /dev/cu.* I get the following:
    /dev/cu.Bluetooth-Incoming-Port /dev/cu.lpss-serial2
    /dev/cu.iPhone-WirelessiAP

    What seems weird to me, is that I also get the exact same answer when the lopy is not connected and turned off.

    Does this not look like a usb driver issue to you?

    EDIT:
    Also, trying to run screen command on the cu.lpss-serial2 just enters a blank terminal session

    Best
    Søren



  • I had that problem for while, but it is now solved.

    1: uninstall Pymakr
    2: install Atom + plugin: Platform-IO
    3: install Filezilla (or some other FTP client)

    In order to upload a file:
    Join your boards wifi
    Upload all files via FTP-client
    Open Serial Monitor in Atom (or Arduino if u like) while connected to board via wifi

    Watch all mentioned workarounds work.

    Wait for Pycom to release plug-in.


  • administrators

    Hi @soren, we are in the process of retiring Pymakr (we are aware of some of the current issues). What I would suggest in the meantime is that you use your terminal to navigate into LoPy.

    These are the commands that I use:

    You should first list all of your USB serial devices.

    $ ls /dev/cu.*
    

    From this list, you'll see a device that looks something like "cu.usbserial-your device

    You can then open a screen session with the device which will open into the REPL.

    $ screen /dev/cu.usbserial-*your device* 115200 
    

    Let me know how you get on!

    Thanks,

    Alex



  • I'm having the same problem, and it's becoming quite annoying.

    • Running OSX 10.12.3, installed latest ftdi drivers (despite ftdi said the latest they had was for 10.5 - 10.7).
    • installed newest lopy firmware via a friends pc
    • connected via wifi (my own mac) and uploaded boot and main files

    I'm connecting to this device: /dev/cu.lpss-serial2
    And leaving it no user or password since the quickstart says that's not necessary.

    This is extremely little intuitive coming from an arduino background I must say. Any advice on what to do, or is osx 10.12.3 just not supported by Pycom?

    Yes I could just stick to the wifi connection, but this is really not optimal because I often have to be on the internet while I'm working.

    Best
    Søren



  • Currently the best solution I have for syncing new code to the LoPy is to do a safe boot (which requires connecting pin 12 (G28) to 3V3) then accessing the device via WLAN and telnet and doing a facory reset on the filesystem (os.mkfs('/flash'). This is by no means ideal.



  • Ok I connected over WLAN via ftp and renamed boot.py and main.py. Now REPL works again.



  • Same here. Even with safe boot I get "Could not enter friendly repl". I can connect over WLAN with telnet...

    I'm running the latest firmware for the LoPy and I'm using the latest version of PyMaker.


Log in to reply
 

Looks like your connection to Pycom Forum was lost, please wait while we try to reconnect.