Damaged WiPy 3.0

  • Hi!

    I've been recently messing around with WiPy and esp-idf. I've loaded example project and left WiPy development for few weeks . Now when powering wipy nothing happens. I've tried to connect via telnet but nothing happens. After connecting P2 to GND LED is green and nothing more happens, still no answer from telnet. Hardware reset via connecting P12 to 3v3 don't work. I can't do nothing with my wipy right now.
    Is there any chance that my WiPy is bricked permamently?

    Now green LED is not showing up.

  • @EngeenerAtendee From menuconfig did you change the flashing port ? In the esp-idf it is set to /dev/ttyUSB0.

    Can you download the the Pycom firmware updater and do an erase all from the cli ? Then try to re-flash using the Pycom updater.

  • @robert-hh
    I've done firmware update and now it is working. Thanks for reply.

  • @EngeenerAtendee P2 to GND is only required for firmware update. And that is something you could try. Do you have an expansion board or a simple USB/UART bridge?

    About the LED: Since P2 is also connected to the LED, pulling P2 low may cause the LED to change colors. But that is just random and no sign for a (mal-)function.

Log in to reply

Pycom on Twitter