LoPy4 stuck in rebooting loop

  • Hi,

    I got my first LoPy4 and an expansion board a few weeks ago. Only yesterday I finally had time to test it, but unfortunately it seems to have died on me after a few hours. It is now stuck in a rebooting loop.

    This is what I tried to pull the LoPy back into life:

    • Safeboot does not work - the procedure is ok, the led flashing and all, but no matter at what time I leave the safeboot selection, the LoPy keeps rebooting.

    • I can run the pycom firmware upgrade utility and flash any version I like, but nothing helps. The upgrade process completes without errors, but the LoPy keeps rebooting.

    • Putting a wire between P2/G23 and ground, I managed to get the LoPy into bootloader mode. I erased the flash using esptool and installed the firmware again using the pycom utility. No change, still rebooting.

    • I also tried all of the above without the expansion board.

    The error seems to happen very early during the boot. I would really appreciate any suggestions you may have....


  • Thanks catalin , the pycom-fwtool-cli command worked for me, I thought I had bricked my lopy4

  • Hi @toffee,

    In some cases, the NVM partition needs to be formatted. For this a format of whole Flash Memory should be performed.

    This can be done using the cli version of the Firmware Update Tool, so please navigate where the app was installed (search for pycom-fwtool-cli executable) and execute:

    pycom-fwtool-cli -p <PORT> erase_all

    <PORT> should be replaced with the actual USB COM port, for example:

    • on Windows COM10
    • on Linux /dev/ttyACM0
    • on MacOS /dev/tty.usbmodemPy8eaa911

  • @toffee Please can you fill an RMA form ?

  • ... I used the pycom firmware updater. The last version I installed is 1.20.1.r1 from pybytes. I used the version that seems to be downloaded in the background automatically. I did not try to upload any files I downloaded myself. I selected to erase the file system during upload and I left the selection at FatFS.

    I have tried several legacy versions of the firmware, but none worked. Should I try something else?

  • @robert-hh

    Thank you for taking the time. Yes, I am sure it is an official LoPy4 device, I ordered it directly from pycom in September, but I only took it out of the box a few days ago.

    Below is the console output taken from Atom at the beginning of each reboot attempt. Not shown is the rest of the core dump. After the core dump, everything repeats.

    Any ideas? I am especially curious to learn if there is anything I may have done wrong. I have never even connected anything to the LoPy except for the expansion board - and nothing to that either. All I did was connect to WLAN and try to get an MQTT client over TLS running.... No sensors yet.

    I would be really grateful for any advice you may have.



    ets Jun  8 2016 00:22:57
    rst:0xc (SW_CPU_RESET),boot:0x13 (SPI_FAST_FLASH_BOOT)
    configsip: 0, SPIWP:0xee
    mode:DIO, clock div:1
    entry 0x400a05d0
    Guru Meditation Error: Core  0 panic'ed (LoadProhibited). Exception was unhandled.
    Core 0 register dump:
    PC      : 0x401383c3  PS      : 0x00060530  A0      : 0x8012a6e0  A1      : 0x3ffb4170
    A2      : 0x3fbc08c4  A3      : 0x3ffb41d0  A4      : 0x15140450  A5      : 0x3ffb42a8
    A6      : 0x0000000a  A7      : 0x3ffc0480  A8      : 0xb33fffff  A9      : 0x0000cdcd
    A10     : 0x3ffbf520  A11     : 0x00060720  A12     : 0xb33fffff  A13     : 0x0000cdcd
    A14     : 0x000000fe  A15     : 0x3ffb71b0  SAR     : 0x0000001f  EXCCAUSE: 0x0000001c
    EXCVADDR: 0x1514054d  LBEG    : 0x4013d894  LEND    : 0x4013d8a0  LCOUNT  : 0x00000006
    Backtrace: 0x401383c3:0x3ffb4170 0x4012a6dd:0x3ffb41d0 0x4013d593:0x3ffb4250 0x4013d8b2:0x3ffb4270 0x40208223:0x3ffb4290
    ================= CORE DUMP START =================

  • @toffee You made all the right steps to revive a device with a wrong flash content. Some simple questions: So you are sure it is a LoPy4 device and you installed the LoPy4 firmware? The firmware updater will tell you.
    Can you show a screen dump of the first few dozen lines after boot or Reset? Maybe it shows a reason.

Log in to reply

Pycom on Twitter