[lopy4] no WiFi on startup



  • Inspite of the blue heartbeat, there is no WiFi AP after starting the lopy4 device.

    • I successfully erased flash using esptool.py erase_flash and later successfully updated the firmware to 1.16.1 using the pycom firmware update tool on Ubuntu 18.04.
    • I used a USB UART Serial device on port /dev/ttyUSB0 (Slilicon Labs) to erase flash and update firmware on the lopy4.
    • When I use miniterm.py, I can see the python terminal and can execute basic commands like changing led colors.

    Below is the print I see on bootup

    ets Jun  8 2016 00:22:57
    
    rst:0x1 (POWERON_RESET),boot:0x12 (SPI_FAST_FLASH_BOOT)
    configsip: 0, SPIWP:0xee
    clk_drv:0x00,q_drv:0x00,d_drv:0x00,cs0_drv:0x00,hd_drv:0x00,wp_drv:0x00
    mode:DIO, clock div:1
    load:0x3fff8020,len:8
    load:0x3fff8028,len:2136
    load:0x4009fa00,len:19880
    entry 0x400a05d0
    Smart Provisioning started in the background
    See https://docs.pycom.io/smart for details
    Pycom MicroPython 1.20.1.r2 [v1.11-06dfad0] on 2019-11-30; LoPy4 with ESP32
    Pybytes Version: 1.3.0
    Type "help()" for more information.
    

    This leaves no option but to type out each python command on the terminal, rather than using easier ways of ftp and using pymakr VScode for uploading code to the lopy4. Also, to be clear: I do not posses any expansion board/Pytrack/Pysense/Pyscan device and have been using a usb-serial-uart module for formatting, upgrading firmware or uploading code.

    I read on https://forum.pycom.io/topic/5338/no-lopy-4-wifi-after-updating-the-firmware about similar problems of not having WiFi AP on update, but wanted to verify if it was solved. My final objective would be to try out the pymesh LoRa on two/three modules of lopy4.

    Apologies if the this was posted against the rules of the forum.



  • @robert-hh I will attempt to do so, thank you for the help!



  • @Ph0333nix In STA = station mode, the board connects to your local router as client.



  • @robert-hh said in [lopy4] no WiFi on startup:

    STA

    I am completly new to this, so I am not sure what that is. I will look at the documentation and see what I learn, thanks for your response! :)



  • @Ph0333nix right. Can't you connect your device in STA mode?



  • @robert-hh but then you wont be able to add your device to pybytes right?



  • @nilay994 This could by cause by pybytes, which started. You should be able to stop that with:

    import pycom
    pycom.pybytes_on_boot(False)
    

    And then reboot. The setting is permanent. If that does not work, create a file on you device called pybytes_config.json and the content:
    {"pybytes_autostart": false}



  • Hi! I am having the same problem, did you somehow get it working?


Log in to reply
 

Pycom on Twitter