littlefs vs fatfs differences

  • Hi All ,

    is there any known differences between the littlefs firmware and the fatfs firmware?
    the reason i ask is we have a program with a local webapp for reading a sensor and a config.html for setting setpoints.
    i just updated a new batch of wipy 3 and decided to use the littlefs file system as all our previous versions used the fat.
    everything worked almost identical except our config.html webpage would not come up. it said file not found.
    our index.html came up ok and the readings worked.

    so I only switched back to the fatfs firmware and the exact files but the config.html worked.
    we have a .txt file that reads a setting but other then that i thought both should work the same.

    i tried this on about 5 or 6 different wipys so it was definalty the difference in file systems.
    I updated to the newest firmware RC13 but decided to try a few older ones. every one of them couldnt read the config.html on littlefs.

  • @robert-hh @andreas Gentlemen thanks. that was it. i didnt notice the capital and since fatfs didnt care i didnt look at it.

  • @gt1 The file name is "Config.html", you try to open "config.html". Could you try to rename the file to all lowercase letters. FAT is not case sensitive, but littlefs may be. Actually I am not sure.

  • @gt1
    I just put a wipy that has fatfs firmware with the same folder/ files on it and ran this command f = open("config.html")
    and it worked with no errors.

  • @gt1 From that screenshot, it looks like the file is called Config.html. Please note the capitalization of the first letter.

  • @robert-hh here is the screen shot of the dir and showing an error opening the config.html file
    which i tried opening the index file and it worked.


  • Dear @gt1,

    if you like, you might want to try an unofficial firmware build [1] from our pen where we tried to mitigate some issues with LittleFS the other day.

    Let me know if this works for you.

    With kind regards,

    [1] WiPy-1.20.2.rc3-0.8.0-vanilla-squirrel.tar.gz

  • @gt1 FileZilla should be fine. Can you open the file from REPL, like:

    f = open("config.html")

  • @robert-hh
    I just looked at the files from filezilla. I looked in the folder and the file was there.
    i did not do the repl commands but i could try this.

    it was strange that it happened on all of the 5 or 6 wipy i tried.

  • @gt1 How did you verify that the files were actually stored in the file system. Did you run from the REPL something like:

    import uos

  • @robert-hh
    yes it was in the same folder. i have a complete folder i transfer over for our project so it is 100% identical to the same files running with the fatfs file system.

    this setup has been running over a year whenever we get new wipy in we normally just flash to the newest firmware and it runs fine with putting the files over.

    but this time i decided to try the littlefs firmware.

  • @gt1 It is a matter of the file name or it's content. And did you place the file config.html in the same directory as index.html?

Log in to reply

Pycom on Twitter