failed to connect to COM port



  • Hi !
    I ask for your help because I can't connect myself on my pytrack anymore.
    Before today I didn't have any issue with Pymakr on atom but today I can't do anything.

    My pytrack's firmware is up to date, and I'm on the 2.1.1 version of pymakr.

    I have this error in the REPL :
    Capture REPL.PNG

    I can see the pytrack on the COM PORT 15 in the device manager.

    Sometimes I can see what my board is sending on the serial port but I cannot upload or run my program...

    Have you an idea of what could be the problem ?

    Thank you.



  • @CeylordZ I suspect the issue is because the USB connection goes away in sleep - but I have no idea how you get this back without restarting the serial connection from the PC



  • @ShanevanJ I tried and it didn't work. But in the last days I found a issue.
    It seems that when I'm using a program with sleeps I cannot connect it anymore.
    So my question : What does the processor do when it's waking up ? Does it run the boot.py again ? Or do I need to do something specific when the board is waking up ?



  • @CeylordZ if you are using windows, have you tried unplugging the device - then opening device manager and show hidden devices on the device manager and deleting (uninstalling) all the com ports. and then reconnecting your device?



  • I'm using the 1.16.2 version too, I have the same issue but sometimes (I have to try several times) It works, but I don't know why.
    Do you have the issue of the endless research by the pycom upgrader ?



  • @CeylordZ what version of upgrader you using? im using 1.16.2 and it fails to detect any of my pycom modules.



  • Thank you for your answer, I completely reinstalled ATOM, pymakr, the firmware and the pytrack's driver and for now it works.

    Just for me to know, the "pycom upgrade firmware" is the tool that allows you to upgrade the firmware of the Lopy and Zadig (and the dfu-util) is for the pytrack's firmware, that's it ?

    And second question, am I the only one who have is board unstable ? Sometimes I want to upload but it does'nt works,so I have to unplug/plug several times and then it's okay...

    Do I need to reboot the lopy when I want to upload ?

    Thanks !


  • Global Moderator

    Hi @CeylordZ. Are you sure you have Pymakr 2.1.1? According to that screenshot, it seems you have Pymakr 2.0.2. Have you tried completely uninstall Pymakr and then install it back again? To do so, remove pymakr folder under

    %USERPROFILE%/.atom/packages/ (windows)
    or
    ~.atom/packages/ (linux/mac)

    and then install Pymakr again.

    Let me know if that worked for you.

    Thanks



  • Has anyone an Idea ?

    I tried some previous versions of Pymakr, I tried to update my firmware again but nothing works.
    I don't know what to try ...


Log in to reply
 

Pycom on Twitter