GPY continuously rebooting rst:0x7 (TG0WDT_SYS_RESET)...

  • The GPY module was used with user program. Then I needed to use it for another purpose, I reinstalled FW (tried multiple versions from 1.20.rc4 to most new one, all in legal or pybytes settings); flash was deleted/formatted along with fw installation and also afterwards in ATom REPL to get a clean module. (Using Exp board v. 3.1)
    The GPY keeps restarting with:

    rst:0x7 (TG0WDT_SYS_RESET),boot:0x13 (SPI_FAST_FLASH_BOOT)
    configsip: 0, SPIWP:0xee
    mode:DIO, clock div:1
    ho 0 tail 12 room 4
    entry 0x400a05f4
    Initializing filesystem as FatFS!

    I found similar issue in ESP32 forum:

    Pls help - how to get rid of this using pycom REPL? (I'm not experienced hacker in ESP kernel...). The same module does not give also WIFI access point when powered up.

  • It really worked! Thank you so much, KJM!
    What I did:
    Connected P2 to GND, pressed reset on Exp Board v3.1. The connection P2 to ground was left on for all the deleting process time.
    Then I did as instructed and result is clean module; reflashed fw as usual with FAT and everything worked and I was able to update NB modem. Also, the previously disappeared wifi at power up was back.

    The problem is associated probably with using adhoc wifi and filezila before I tried to clean the module for another application.

    C:>cd Program Files (x86)

    C:\Program Files (x86)>cd Pycom

    C:\Program Files (x86)\Pycom>cd Pycom Firmware Update

    C:\Program Files (x86)\Pycom\Pycom Firmware Update>
    C:\Program Files (x86)\Pycom\Pycom Firmware Update>pycom-fwtool-cli list
    COM6 [USB Serial Device (COM6)] [USB VID:PID=04D8:EF98 SER=PY7C4EA8 LOCATION=1-1]
    COM3 [Intel(R) Active Management Technology - SOL (COM3)] [PCI\VEN_8086&DEV_A13D&SUBSYS_07D01028&REV_31\3&11583659&0&B3]

    C:\Program Files (x86)\Pycom\Pycom Firmware Update>pycom-fwtool-cli.exe -p COM6 erase_all
    Running in PIC mode
    Erasing the board can take up to 40 seconds.
    Board erased successfully in 11.61 seconds

    C:\Program Files (x86)\Pycom\Pycom Firmware Update>

    1. Not all flash erasures are created equal, the one that definitely does a full flash erase runs not from Atom but the windows cmd line with Atom closed down. My notes on same herewith:
      Full flash erase using pycom-fwtool-cli (P2 to gnd, press reset button on dev2.0 board)
      cd \Program Files (x86)\Pycom\Pycom Firmware Update
      pycom-fwtool-cli list to get com port eg COM3
      pycom-fwtool-cli.exe -p COM3 erase_all (gives ‘access denied’ if Atom using the port)

    2. Maybe try reflashing with littleFS option in lieu of FatFS?

Log in to reply

Pycom on Twitter