Pymakr doesn't find any serialports

  • Hello!
    i just looked for a IDE to get in Touch with my ESP32-Cam, so i found VSC and Pymakr.
    Now i encountered a problem. Pymakr wont find any Serial Devices. :-/
    Tested on Ubuntu (i think 18.04) and Arch Linux.
    When i trigger "List serial ports"

    Found 0 serialport (nothing else)

    My shell:

    MadMe86@MyPC ~ % ls -la /dev/ttyU*
    crw-rw---- 1 root uucp 188, 0 13. Apr 18:55 /dev/ttyUSB0

    and i am in the uucp group(Thats the Arch dialout group). Thonny is connecting just fine.

    My Device is an ESP32-Cam. (Should be compatible with Pymakr, right?)

    I tried VSC and Atom(on Arch) but both don't show any serial devices. On the Ubuntu machine i tested the app with VSC as snap package and as native installed app.

    Am i missing something?

    Thanks in Advance!

  • @MadMe86 maybe its a permission problem. I had a similar issue and this solved it for me.

    sudo chmod 666 /dev/ttyUSB0

    let me know if this solved your problem or how did you fixed it.

  • @cdjambov

    Thanks for your reply!
    but that did not do the trick... still the same...

    Are there any log files which i could check? or a verbose mode to activate?

  • This post is deleted!

  • @MadMe86 said in Pymakr doesn't find any serialports:

    When i trigger "List serial ports"

    Try adding pymakr.conf into the project folder and fill it with something like this.
    "address": "/dev/ttyUSB0",
    "username": "micro",
    "password": "python",
    "sync_folder": "",
    "open_on_start": true,
    "safe_boot_on_upload": false,
    "py_ignore": [],
    "fast_upload": false

Log in to reply

Pycom on Twitter