LoPy4 crash

  • Hello
    My Lopy4 card crashes if it runs a script for a long time even with a small script like :

    import utime
    While True:
        print ("ok")

    errors are never the same and are never at the same time. I don't understand why and I may have updated the boards, but that doesn't change the problem. Where could the problem come from?

    my last error :

    Guru Meditation Error: Core  0 panic'ed (LoadProhibited). Exception was unhandled.
    Core 0 register dump:
    PC      : 0x4014cc3f  PS      : 0x00060133  A0      : 0x80086e6f  A1      : 0x3ffd4780  
    A2      : 0x00000000  A3      : 0x00060123  A4      : 0x00060120  A5      : 0x00000001  
    A6      : 0x000000fe  A7      : 0x00000000  A8      : 0x60008890  A9      : 0xd0dd1b01  
    A10     : 0x00000000  A11     : 0x08070902  A12     : 0x3ffd48ac  A13     : 0x00000001  
    A14     : 0x000000fe  A15     : 0x00000000  SAR     : 0x0000001e  EXCCAUSE: 0x0000001c  
    EXCVADDR: 0xd0dd1b01  LBEG    : 0x4009347c  LEND    : 0x400934aa  LCOUNT  : 0xffffffff  
    ELF file SHA256: 0000000000000000000000000000000000000000000000000000000000000000
    Backtrace: 0x4014cc3f:0x3ffd4780 0x40086e6c:0x3ffd47a0 0x4015224d:0x3ffd47d0 0x401570f0:0x3ffd4800

  • @Gijs I assume that not. I am running a version from months or years ago, and with the Loriot network. I can send you a copy of that nanogateway script.

  • @robert-hh are you running the nanogateway.py example that we provide? I have not been able to get that running stable for more than a day yet :/

  • @robert-hh 96 days since the last stop and still working fine. Similar for the LoPy1 which runs as single channel Lora gateway, which restarted twice in that time, both caused pulling unintentionally it's power plug.

  • @mythael I stopped the test yesterday after 44 days for loading the latest firmware 1.20.2.rc9. The device was still up and working.

  • @mythael 21 days on the road an still running.
    A note on the USB supply I am using: it is a dumb one. Just delivering 5V up to 1A without any protocol.
    From time to time I connect via Telnet as an additional verification besides the green LED coming up every 20 seconds.

  • @mythael I have set-up a LoPy4 with a similar script like yours, and it is running not continuously since 10 days without any crash. The script is below. It blinks green every 20 seconds. The LoPy4 is powered by a separate USB supply & not connected to a computer. I use my own simple expansion board with FT232 USB/UART bridge. The firmware is 1.20.2.rc7, but my own build.

    import pycom
    import utime
    while True:
        print ("ok")

  • @robert-hh I'm using version 1.20.2.rc7 and the card is USB powered. I tried it on a 3.1 extension card and a Pysense card.

  • @mythael which firmware version do you use? How do you power to the device?

  • @robert-hh it depends in general it takes 4 hours or less (the fastest crash observed is 10 minutes) with this little script it took 15 hours. I also tried with another Lopy4 but I have the same problem.

  • @mythael How often does that happen? Every few Minutes, once an hour, once a day, once a week?

Log in to reply

Pycom on Twitter