Installing WiPy3 using Expansion Board 2.1 on Win10



  • Trying to get things installed on my Win10 laptop for WiPy3 using the older Expansion Board (2.1). I also have PySense (1.1) that I will be attempting to get installed later.

    I'm trying to follow the instructions in Getting Started which states that you shouldn't need to install drivers when using Win10. I'm attempting to update firmware and have G23 connected to GND on the Expansion Board. But, when I plug the Expansion Board/WiPy3 USB into the laptop, device manager doesn't list any COM ports and the Update Tool exits. Even without the jumper installed, no COM ports are listed. The boards appear to be powering up properly, I get the GREEN USB light on the Expansion Board and the BLUE LED heartbeat flashing (but no COM port). With the jumper installed, I still get the GREEN USB light but no heartbeat.

    How do I proceed?

    Thanks



  • Yes, the WiPy3 is installed correctly. As I stated from the start, I get the blue heartbeat LED flashing upon USB connection (obviously wouldn't get that if it wasn't installed correctly). I get NO COM ports assigned at all.

    I also plugged the WiPy3 into the PySense and tried to connect that to USB as well but same result (nothing happens, no COM ports assigned). It appears Windows is not seeing the USB connection and/or doesn't know what to do with it. Generally when a device is connected to USB, Windows makes a tone so you know the device was recognized. In my case, it does nothing. I'm going to try this on another laptop of mine and see if it works on that machine (still Win10). I also have a Rasp-Pi4 running Linux, so I'll try it there too to see if it at least gets recognized (I understand the drivers are different under Linux but I'd like to at least confirm that there isn't a hardware problem with the Expansion Board/PySense or the WiPy3). I also have a WiPy2.1, so I will also try everything with that to see if I get any better results.

    Are there any log entries produced that would at least let me know that Windows is seeing this and is just having trouble determining what to do? If so, where can I find the log file? Really need to try to figure out what's going on so I can get this connected and operating. Appreciate any help.



  • @sealyons Hard to tell. Expansion board 2 is normally well behaving, and it works here w/o problems. I assume that you look in the device manager for available com ports. There are jumpers on the board, but these are at the micro side of the USB/UART bridge. And the COM port should get visible even without the WiPy3 installed. Are you sure that you plugged in the WiPy3 with the right orientation? The LED has to be at the USB connector side.



  • I've tried several USB cables (known to work with other devices) but I get the same result. I also installed the FTDI VCP drivers from https://www.ftdichip.com/Drivers/VCP.htm for Win10 x64 via the setup executable option. I re-booted but still don't get any COM ports listed and nothing happens when I plug the WiPy3 in. Not sure what else to try. Any thoughts?



  • @sealyons You should see the COM port even without the WiPy3 installed. So it is most likely the FT234 USB/UART driver that is missing. You may also check the USB cable. Some USB cables supplied with smart phones only have the power wires, but not the data wires.


Log in to reply
 

Pycom on Twitter