Sigfox Downlink ENETDOWN - LoPy4

  • Hi,

    I have a question regarding the downlink connection in sigfox. Every time I try to send a message with downlink enabled I get a ENETDOWN error. In the sigfox backend I can see that the downlink message has been ackd.

    I've read somewhere on this forum when discussing the fipy, that this may be due to the downlink connection using sigofox fsk mode, which also does not work on the Lopy4 as written in the documentation.

    Is my problem related to fsk mode not working on the lopy4? If not, what could be the problem?

  • @miwink Better use wavelength/2 antennas, even if they are larger. The first one @Eric73 linked or the pycom antenna are such. They are more forgiving in handling.

  • @miwink I am not an expert in atenna but here some exemple of antenna that can be used, you can try to change your uFL-SMA cable too

  • @Eric73 Ok, so I will try that. I don't know that much about antennas, are there some sort of requirements for what type of antenna it should be. Or all they all pretty much the same?

  • @miwink So it must work, try different antenna or even try outisde building you must receive your downlink.
    Please note that sigfox downlink message is very limited, no more that 4 by day is allowed, so shutdown your board for 24 hours, then try outside or with a new antenna. Each time the sigfox bacjend send you a message you go nearest the limit of message allowed for you.

  • @Eric73 Screenshot 2020-07-02 at 08.20.46.png

    All downlink messages have identical details.

  • @miwink In Sigfox backend, can you click on the green down arrow to see detail about downlink sigfox status and post result?
    LQI: Link Quality Indicator is ggod for uplink, so downlink must work too

  • @miwink

    QUICK UPDATE: Fixed the pymakr access problem, had to reset everything, like the flash, the config and the nvs partition. Now it works.

    The sigfox downlink is still not working though.

  • @Eric73

    Well, now I did something stupid and updated the firmware, thinking that might have been the problem with downlink not working. The result is that I know can’t access the repl with the pymakr plugin (stuck at connecting to ...), can’t download or upload anything (stuck at download fail: timeout, reset manually) and can’t update the firmware as I only get sha1 error checksum. I use the latest tools and firmwares.

    I can update the lopy through the advanced settings of the update tool, but the problem persists.

    I suppose there is a way to fix this, but I don’t know how.

  • @Eric73 Hi,

    Thanks for the reply!! :D

    I see, nice to at least get some sort of confirmation that it is supposed to work on the LoPy4, the documentation and some other posts are not very clear whether the lopy4 supports downlink or not (in my opinion).

    Screenshot 2020-07-01 at 14.13.26.png

    For now I have tried both downlink callbacks and Direct downlink, and both seem to become acked in the sigfox backend, but I still get enetdown on the device. As you can see in the picture the downlink was acked by the network. In this message I used the direct downlink provided by the backend, that always replies with "deadbeefcafebabe".

    Maybe it has something to do with my connection quality?

  • @miwink Hi, Lopy4 doesn't support sigfox FSK in point to point mode, but don't worry it receive sigfox fsk downlink from sigfox network.

    OK on sigfox backend you see what exactly (you can post picture of your message satus)? Have you set some data in your downlink callback ?

    My Lopy4 work fine in sigfox with uplink/downlink since 2 years now in field so keep hope that your work with downlink :-)

Log in to reply

Pycom on Twitter