PyGate PoE Issues

  • Hey folks,

    I've received my PyGate through the post this morning, but the PoE adaptor doesn't seem to work.

    I can't find any instructions in the docs, nor were there any with the adaptor itself, so I'm struggling to bring it online.

    It's attached to a Unifi 24-power PoE switch with autosensing 802.3af PoE enabled, however when I plug the adaptor in to an ethernet cable the port on the switch doesn't detect anything at all, and there are no lights on the unit.

    I've checked the pin reference on the adaptor and the pygate board a number of times and confirmed that the board is seated the right way around (again, documentation would have been useful here rather than having to read the pin mappings on the PCB!), but still no joy.


  • Hi @robert-hh, hi @jcaron ,
    thanks for your replies.

    Sorry, I meant an PoE Splitter, which works fine and PoE supply direct from the switch did not work.
    I received my PyGate 2 weeks ago (shipped 30.06.) or so with one year delay. I don't know if this is an early version or not. I'll check this.

    ...5 minutes later....
    Yes, I'm affected from this bug. Unbelievable. I thought the problem was my Netgear switch.
    What I don't understand is that Pycom did not inform people who ordered the PyGate with PoE....
    I'll try to swap D2.

    ...5 minutes later...
    Ok, my PoE Adapter is working as expected. I cut all pins from the RJ45 connector to avoid shortcuts. Hopefully the PyGate Enclosure will arrive soon.

    Thanks for your quick help.

    Best regards

  • @schmelpe I suppose you mean you use a PoE splitter, not injector for the scenario that works?

    Pycom have published here that there is an issue with some early PyGate PoE adapters which result in the PoE function not working.

    You can either contact them to have the board replaced or just switch the orientation of one component on the PCB. Details are available in the post linked above.

    But it does indeed point to another lack of QA...

  • @schmelpe So you're saying that

    • PoE supply for PyGate works if you use a PoE injector and an USB C power source, but
    • PoE supply for Pygate fails if you used the switch as power source.

    In this case, your problem is different. The assembly failure discussed here results in PyGate not being powered at all trough the Ethernet cable. There are so called PoE switches, which do NOT power attached devices themselves, but are only able feed though PoE power from a separate supply. Sometimes this is an advantage.

  • Same problems here as described.
    PoE is not working connected to a Netgear PoE Switch.
    Connecting an PoE Injector between the PoE Module and plugging the output to the USB-C Port is working.
    It's unbelievable that this is not working after one year of delay in delivery.
    Why does no one from Pycom replies to to this topic here?
    This is the second product from Pycom which did not work as expected (after the LoPy DeepSleep debacle).

  • Connecting a laptop via USB-C is OK provided it is not plugged in or uses an earth protected charger.

    I put a thin piece of plastic between the POE adaptor and heatsink while it is outside an enclosure. I believe the adaptor would be supported correctly once in the official enclosure.

    I've used the ethernet information in to create an updated basic application that uses the ethernet interface rather than WiFi. Configured via DHCP works well.

    It is disappointing that the POE part is not working as expected.

    I did notice under the Pygate the silkscreen for the additional header, wondering if this could be used to connect a compatible GPS module to provide 1PPS and location data into the packet forwarder.



  • Picking this up here from Twitter, and yes, I agree there's a real danger that the PoE could short on the heatsink - at first that's exactly what I was worried was happening.

    I've not connected the ethernet and USB at the same time yet because the instructions at seem to suggest that this is a BAD THING.

    I'll be blunt, I'm disappointed that I've waited for well over a year for this to arrive only to find that it's just the basic packet forwarder, that the tutorials only cover getting it talking to TTN, and that the PoE doesn't work... :(

  • I've tried my POE adaptor, cable works with another POE adaptor so I know the port works. I see no LEDs lit on the POE adaptor, no LED on the switch to indicate it has a connection. It all looks dead.

    However, when I connect my laptop via a USB-C cable the gateway comes to life, the ethernet switch detects the port and the LEDs on the RJ45 socket become active.

    It's supposed to be Power Over Ethernet not Power Over USB with Ethernet for good measure.

    I connected a small lithium battery pack to the connector then reconnected the POE adaptor. This seems to bring the POE adaptor into life as I'm guessing the battery is now powering it. However, the POE is not charging the battery.

    Upon plugging in the USB cable the charge LED came on.

    Laptop is running on battery, connected to Pygate via USB-C cable, Pygate POE adaptor plugged into one of the POE ports on my TP-Link TL-SG1008P ethernet switch.

    What are we missing here?

    Also, the POE adaptor could potentially come into contact with the heatsink below it and shorting some of the pins from the RJ45 socket.


Log in to reply

Pycom on Twitter