Pytrack 2.0X and GPy not detected on Atom



  • I am using a MacBook Air 2018 and I connected my Module (pytrack 2.0x and gpy) using a micro usb cable and usb to usb c adapter. However, when I launch Atom, it says that no device is connected. Funnily enough, there is a heartbeat on the module (blue light flickering) and I can run files using the wifi function but it is quite inconvenient. I verified that its not the port as I used an Arduino and nor is it the cable as I tried a different one. Any solution?



  • @Gijs Hi, thanks a lot! I wasn't aware that certain micro-usb cables are like that. After some searching, I found one cable that worked. Thanks again!


  • Global Moderator

    Hi,
    Make sure your USB cable setup also passes through communication, not just power. It is common for USB micro to USB C adapters to just pass power and not data. Im not 100% sure whether the setup would work at all and if other USB C conductors are used..
    If this is not the issue, you can check whether the board is recognized using lsusb in the terminal. It should show a Pygate device.
    Let me know!
    Gijs


Log in to reply
 

Pycom on Twitter